lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-18-2016, 03:55 PM   #1
Not Yet Wild
 
Join Date: May 2016
Posts: 4
Unhappy No Headlights, but all other lights work properly

Have 2002 Club Car 48V Electric with dealer installed headlights, marker lights, taillights and turn signals. 20A fuses on marker lights/tail lights. 20A fuse on headlights.
Was installing 12V power outlet and accidentally grounded screwdriver from headlight switch to 48V main ignition switch. Pow!
Blew fuse for marker lights and taillights. Replaced it and all those lights now work normally.
However, headlights do not work. 20A fuse on this line did not blow.
All lights work on 16V DC.
Have 16V DC at the headlight on/off switch.
Can't seem to get the headlights out of the fender, they seem to be held in with some type of detent, not screw mounted. Don't want to break the plastic housing.
Do you think both lights blew from the momentary high voltage spike? Is there some other components that might have blown?
Would appreciate any help.
Thanks.
Mike in The Villages is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-18-2016, 03:59 PM   #2
Gone Wild
 
theboss20's Avatar
Harley Davidson
 
Join Date: Jun 2014
Location: Buckeye, Az
Posts: 644
Smile Re: No Headlights, but all other lights work properly

Chances are with that high voltage it blew the bulbs...you could do a continuity test but it's almost not worth it...just order new ones and disconnect the batteries next time...
theboss20 is offline   Reply With Quote
Unread 05-18-2016, 04:07 PM   #3
Not Yet Wild
 
Join Date: May 2016
Posts: 4
Default Re: No Headlights, but all other lights work properly

Sounds like the right thing to do.
I'm puzzled as to how to get the headlights out of the fiberglas cart body. There are no mounting screws. Is there a detent somewhere that has to be depressed?
I am concerned I might break the plastic housing by prying on it.
Thanks for your help.
Mike
Mike in The Villages is offline   Reply With Quote
Unread 05-18-2016, 05:25 PM   #4
Not Yet Wild
 
Join Date: May 2016
Posts: 4
Default Re: No Headlights, but all other lights work properly

Was able to reach up behind the headlights, grab the main connector and twist c'clockwise and the lamp bulbs came out. Yes, they were burned out. So, will try to find some tomorrow so I can put things back together.
Doesn't look like the main headlight assembly comes out very easily.
Mike in The Villages is offline   Reply With Quote
Unread 05-18-2016, 08:54 PM   #5
Gone Wild
 
Htownblue's Avatar
Club Car
 
Join Date: May 2015
Location: Houston
Posts: 334
Default Re: No Headlights, but all other lights work properly

Quote:
Originally Posted by Mike in The Villages View Post
Was able to reach up behind the headlights, grab the main connector and twist c'clockwise and the lamp bulbs came out. Yes, they were burned out. So, will try to find some tomorrow so I can put things back together.
Doesn't look like the main headlight assembly comes out very easily.
Replace with LED's friend. Not too much more expensive and you can easily get the correct fit bulb in LED.
Htownblue is offline   Reply With Quote
Unread 05-18-2016, 08:59 PM   #6
Gone Wild
 
glassk's Avatar
Club Car
 
Join Date: Dec 2011
Location: Hampton, GA
Posts: 441
Default Re: No Headlights, but all other lights work properly

Worked in our DS,...
Attached Images
File Type: jpg 61N+ySLl-SL__SL1001_.jpg (96.3 KB, 0 views)
glassk is offline   Reply With Quote
Unread 05-19-2016, 02:01 PM   #7
Not Yet Wild
 
Join Date: May 2016
Posts: 4
Default Re: No Headlights, but all other lights work properly

Picked up new bulbs this morning and have installed them. Problem solved.
Did not check the Forum this morning but wish I would have.
Would have tried to find LED bulbs.
Will do that next time.
Thanks for the comments.
Mike
Mike in The Villages is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Headlights won't work only marker lights Gas EZGO
Headlights quit working, tail lights still work. Help Electric Yamaha
Break lights and orange front lights work but headlights don't! Electric EZGO
headlights don't work Electric Club Car
Headlights Work When CC IS NOT Going Electric Club Car


All times are GMT -5. The time now is 10:54 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.