lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-15-2009, 11:58 PM   #1
Gone Wild
 
Extractor's Avatar
Club Car
 
Join Date: Nov 2008
Location: Florida
Posts: 479
Default Rear 6" lift not adding up- pic!

1998 CC 48v, kawasaki rear end. Got the All Sports long travel lift. Front was a breeze. Having problems with the rear lift. Here's what I have:



So the U-bolts are not long enough to pass through all the plates! What am I doing wrong? Starting from the top and working my way down there is the first plate with the shock mount on the inside, then the heavy duty leaf spring, then the rear end, then the square mounting plate, then the stock plate with the brake cable attached...
Just realized it when I was typing it that the lift is for the stock leaf springs!! So now I have the heavy duty leaf springs, how do I make it work? Just go to the hardware store and buy longer u-bolts?
Extractor is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-16-2009, 12:04 AM   #2
Getting Wild
 
hillbillyhangover's Avatar
E-Z-GO
 
Join Date: Nov 2008
Location: Utah
Posts: 115
Default Re: Rear 6" lift not adding up- pic!

From your pic it looks like the quickest solution.
hillbillyhangover is offline   Reply With Quote
Unread 01-16-2009, 12:14 AM   #3
A-DMIN
 
chevyrules05's Avatar
Club Car
 
Join Date: Sep 2008
Location: Lake Buena Vista, Florida
Posts: 626
Default Re: Rear 6" lift not adding up- pic!

I had the same problem but it is hard finding that same size ubolt, I would take one of those ubolt to a local metal shop and have them make you some new ones, thats what I had to do, you are in stuart if you can't find anyone get on 95 head up to orange Ave. fort pierce exit and Hickmans is right there on the right they made me four new ubolt for a little over 20 bucks
chevyrules05 is offline   Reply With Quote
Unread 01-16-2009, 12:22 AM   #4
Gone Wild
 
sleezego's Avatar
E-Z-GO
 
Join Date: Dec 2008
Location: Clinton Twp. MI
Posts: 431
Default Re: Rear 6" lift not adding up- pic!

i know around here ACE has the largest selection of any stores for u bolts like that...
sleezego is offline   Reply With Quote
Unread 01-16-2009, 12:28 AM   #5
Gone Wild
 
Extractor's Avatar
Club Car
 
Join Date: Nov 2008
Location: Florida
Posts: 479
Default Re: Rear 6" lift not adding up- pic!

cool, so tomorrow it's off to ACE first then up to Ft. Pierce if I strike out at ACE! Think I'll get some new shocks while it's all torn apart but that's for another thread...

Thanks all, can't wait to get it done, but then what will I do??
Extractor is offline   Reply With Quote
Unread 01-16-2009, 06:47 AM   #6
What the.....?
 
lockman1's Avatar
Club Car
 
Join Date: Jan 2007
Location: N.E. Wisconsin
Posts: 11,402
Default Re: Rear 6" lift not adding up- pic!

Quote:
Originally Posted by Extractor View Post
can't wait to get it done, but then what will I do??
If your like any of us... you'll find something else to add!!!

lockman1 is offline   Reply With Quote
Unread 01-16-2009, 08:58 AM   #7
Gone Wild
 
groundpounder's Avatar
Yamaha
 
Join Date: Sep 2007
Location: maine
Posts: 3,341
Default Re: Rear 6" lift not adding up- pic!

your saying you bought the lift and the u bolts don't fit? so you have to go buy different ones out of your pocket. that's not right. whats this lift so i never buy one thanks.
groundpounder is offline   Reply With Quote
Unread 01-16-2009, 09:08 AM   #8
Gone Wild
 
DOOmsman's Avatar
Yamaha
 
Join Date: Jul 2008
Location: Reddick IL
Posts: 10,985
Default Re: Rear 6" lift not adding up- pic!

How about cut a little off, coupler nuts and 2 inch studs.
DOOmsman is offline   Reply With Quote
Unread 01-16-2009, 09:19 AM   #9
Gone Wild
 
groundpounder's Avatar
Yamaha
 
Join Date: Sep 2007
Location: maine
Posts: 3,341
Default Re: Rear 6" lift not adding up- pic!

oh ok i see not stock springs
groundpounder is offline   Reply With Quote
Unread 01-16-2009, 10:37 AM   #10
Gone Wild
 
Fishing Dude's Avatar
Club Car
 
Join Date: Jul 2008
Location: Slums of Lake Erie
Posts: 3,722
Default Re: Rear 6" lift not adding up- pic!

Could go buy some steel rod, thread ends, bend, and you have made your own. May need to heat treat.
Fishing Dude is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Need Another 1-2" of Lift Lifted Golf Carts
25" tires w/ 6" lift questions? Lifted Golf Carts
89" Marathon with 4" lift....can I fit 23" tires??? Electric EZGO
I want to raise my Jakes 6" lift another inch for a total of 7". Lifted Golf Carts
3" lift for g-16 Design Center


All times are GMT -5. The time now is 01:57 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.