lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-30-2016, 07:26 AM   #1
Not Yet Wild
 
Join Date: Apr 2015
Posts: 9
Default 2010 Club Car Precedent Regen Issue

Hello.
I have a 2010 Club Car Precedent. The ID starts with PQ.
Last season we had no issues with the cart as we had just bought it.
During the winter we had a golf cart guy put it in inside storage and charging.
We got it back and that is where the problems began.
Anytime we went to move the cart the Regen would kick in.
I had a speed sensor around so I changed it and it didn't change anything.
I called the guy and he was supposed to put the computer on it and check it.
Said that it may have reverted back during the winter.
He texted me that the speed sensor was bad, and he changed it.
I went to our campground this weekend and low and behold... Still not right.
This is what I found, and did for more answers...

If I go full speed with the cart it is fine. If I let off the pedal the regen kicks in.
If I gently push the pedal the cart will go... slow.
Once the regen kicks in I have to let off the pedal and try again...
I took the 2 wire plug off the MCOR and jumpered it... Nothing changed.
I did a computer reset... Nothing changed.

Suggestions?

I was thinking the wiper type part maybe has a bad spot in it... Not sure if this has one or not...
I know there is an MCOR with 2 plugs... the 2 wire plug and I believe a 3 wire plug.

I would like a few solutions...
jmarsden92 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-30-2016, 05:22 PM   #2
Gone Wild
 
Htownblue's Avatar
Club Car
 
Join Date: May 2015
Location: Houston
Posts: 232
Default Re: 2010 Club Car Precedent Regen Issue

So after you,let off pedal and regen kicks on, you cannot then push the accelerator down and continue to drive forward or accelerate back to original speed?

The regen system can be set as to how aggressive you want it IIRC. That said I am not sure that is your problem. Neither was your speed sensor I believe.

You have an MCOR 4 on your cart. Though this case does not exhibit the usual MCOR failure symptoms.
Htownblue is offline   Reply With Quote
Unread 05-30-2016, 07:08 PM   #3
Not Yet Wild
 
Join Date: Apr 2015
Posts: 9
Default Re: 2010 Club Car Precedent Regen Issue

If i take foot off and then back on it will go again until the spot is found that regen kicks in again...
jmarsden92 is offline   Reply With Quote
Unread 05-31-2016, 06:47 PM   #4
Gone Wild
 
Htownblue's Avatar
Club Car
 
Join Date: May 2015
Location: Houston
Posts: 232
Default Re: 2010 Club Car Precedent Regen Issue

Sounds like a possible MCOR issue, but you might have it set to a high regen default which would make the regen kick in aggressively. Either way the moment you accelerate again the MCOR should tell the controller to move the cart forward with a purpose.
Htownblue is offline   Reply With Quote
Unread 06-03-2016, 10:59 PM   #5
Gone Wild
 
Nsane's Avatar
Club Car
 
Join Date: Jun 2014
Location: Concord, NC
Posts: 199
Default Re: 2010 Club Car Precedent Regen Issue

Sounds like the Mcor has a bad spot to me. Did you try turning the key off, put it in tow and press the go pedal down like 30-40 times? Sometime it will kinda clean it off for a short time. If that helps than plan on a new MCOR.
Nsane is offline   Reply With Quote
Unread 06-04-2016, 06:18 PM   #6
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: 2010 Club Car Precedent Regen Issue

This isn't very nice and you would never prove it, but it sounds like golf cart guy may have removed your controller for troubleshooting another cart and never replaced it back with your controller. If you didn't have regen last year you shouldn't have regen this year.
But then again you mentioned that he had a computer to check stuff. He could easily turn regen to a minimum if he wanted to and you would be happy.
jjance is offline   Reply With Quote
Unread 06-04-2016, 06:23 PM   #7
Gone Wild
 
Htownblue's Avatar
Club Car
 
Join Date: May 2015
Location: Houston
Posts: 232
Default Re: 2010 Club Car Precedent Regen Issue

I would also check the brakes. Just to make sure they aren't adjusted too tight.
Htownblue is offline   Reply With Quote
Unread 06-26-2016, 07:55 PM   #8
Not Yet Wild
 
Join Date: Nov 2015
Posts: 38
Default Re: 2010 Club Car Precedent Regen Issue

Having similar issues would really like to know end result
Ken taylor is offline   Reply With Quote
Unread 07-04-2016, 08:36 AM   #9
Not Yet Wild
 
Join Date: Nov 2015
Posts: 38
Default Re: 2010 Club Car Precedent Regen Issue

Hey jmarsden92 ,not sure if you still visit would like to know end result to your golf cart issue ,I have same year and issue Thanks
Ken taylor is offline   Reply With Quote
Unread 07-18-2016, 05:20 AM   #10
Not Yet Wild
 
Join Date: Nov 2015
Posts: 38
Default Re: 2010 Club Car Precedent Regen Issue

Need to know if mcor resolved your issue please
Ken taylor is offline   Reply With Quote
Reply

Tags
precedent regen issue
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
1998 club car regen braking issue Electric Club Car
Speed issue on 1998 regen Club Car Electric Club Car
2010 club car precedent Electric Club Car
2010 Club Car PRecedent IQ Electric Club Car
2010 club car precedent-gas Gas Club Car


All times are GMT -5. The time now is 12:24 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.