lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-30-2016, 09:54 PM   #1
Not Yet Wild
Club Car
 
Join Date: Mar 2016
Posts: 32
Default Has my speed sensor been discontinued??

First off I'm new here hopefully I'm posting in the right place. I have a 98 club car ds 48v, I'm having a real hard time getting up hills lately, on flat ground the cart is fine but as soon as it hits a hill it bogs down bad so somebody suggested a speed sensor. I read online to test a bad speed sensor is to let the cart roll down a hill or push it manually while in "run" and if the cart doesn't slow itself down your speed sensor is bad. My cart will roll down a hill for days with no slowing! So I was going to replace the sensor but can't find it anywhere online. It's not the old round clip in style, and its not the newer style that's held in with 2 bolts. Mine looks like a 1 inch square circuit board that's held in underneath a thin oval peice of sheet metal with 3 hex head screws. If sumone can please tell me where I can buy this kind that would be great! Or do I have some sort of alien golf cart technology?!! Thanks ahead of time!
Jayts508 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-31-2016, 08:47 AM   #2
Gone Wild
Club Car
 
Join Date: Jan 2014
Location: Okatie, SC
Posts: 309
Default Re: Has my speed sensor been discontinued??

You need to talk to Tahoedawg here http://www.revolutiongolfcars.com/ he is the CC expert here.
Hecky50 is offline   Reply With Quote
Unread 05-31-2016, 09:28 AM   #3
Gone Wild
Club Car
 
Join Date: Feb 2012
Location: Indio, CA The Desert!
Posts: 1,176
Default Re: Has my speed sensor been discontinued??

I'm not sure that your cart has a speed sensor?? Can you post a picture of this part you are describing?
smokey tennis shoe is offline   Reply With Quote
Unread 05-31-2016, 10:54 AM   #4
Gone Wild
Club Car
 
Join Date: Sep 2012
Location: Alberta - Canada
Posts: 997
Default Re: Has my speed sensor been discontinued??

Sounds like he has Regen-1 or 2 motor (see photo)
Quote:
as it hits a hill it bogs down bad so somebody suggested a speed sensor
Based on your description of rolling down hills, I do suspect your speed sensor is either unplugged or has failed - but a replacement would do absolutely nothing to help you climb hills. In fact a failed speed sensor would actually help your cart drive faster on flat ground. Your barking up the wrong tree.

On a cart that seems to drive normally otherwise - the most likely cause for bad hill climbing is either dead (or dying) batteries; OR battery cables that have degraded over the years that do not carry sufficient current (bad cables will often be warm to the touch after climbing a hill).

My money is on bad batteries.
Attached Images
File Type: jpg Regen-1.jpg (237.3 KB, 0 views)
joesam is offline   Reply With Quote
Unread 05-31-2016, 12:50 PM   #5
Not Yet Wild
Club Car
 
Join Date: Mar 2016
Posts: 32
Default Re: Has my speed sensor been discontinued??

So pic Joesam posted of the sensor is exactly what I have. I wouldn't be able to post a pic u til this weekend as my cart is at the campground. My sensor is still plugged in i checked the plugs and all looks good, unless there's a broken wire sumwhere along the line it sounds to me my sensor is bad. By what your saying i don't even need to fix the sensor because it isn't the cause of my problems besides the not slowing downhill. I have a voltmeter on my dash and after fully charged and let stand a few hrs it reads 50.1-50.3v and going uphill on a full charge it goes down to about 44-47v depending on incline of the hill. I've tested with a hydrometer and I only have one cell that's just in the red, all other cells are in the green, could it be that one cell alone causing this? I was really hoping to hear it was just worn brushes becuz 100bux vs 800bux would mKe my wallet a lot happier!
Jayts508 is offline   Reply With Quote
Unread 05-31-2016, 01:55 PM   #6
Gone Wild
Club Car
 
Join Date: Sep 2012
Location: Alberta - Canada
Posts: 997
Default Re: Has my speed sensor been discontinued??

Many people bypassed or unplugged their sensors on Regen 1 and 2 carts just for faster downhill performance. Yours is Regen 2 because you said it has a run/tow switch.

Your cart may have been modified - and the easiest way to tell - is if you still have two solenoids. One of which is on the lower passenger side frame rail with a big wire loop/coil attached. If its missing, you've been modified.

The best way to test your batteries (as a pack and individually) is described in THIS THREAD. The article describes a cart which is not the same drive system as yours - but the battery test procedure is exactly the same for almost any cart. Because you said its top speed is unchanged on flat ground - then its not likely your "multi-step potentiometer" (sometimes called v-glide).

If its not your batteries - then check all the "big" cables for corrosion/degradation (preferably replace them with 4 ga. rather than 6 ga.) to pass more current. They all would need to be replaced for the bigger cables to give you any improvement in hill climbing - even the longer ones that attach to the motor.
joesam is offline   Reply With Quote
Unread 05-31-2016, 03:09 PM   #7
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,977
Default Re: Has my speed sensor been discontinued??

Joesam is correct about everything he's said. However, for future reference of anyone who sees this thread. The part number for the Regen 1 and Regen 2 speed sensor is 101925801, and yes it's still available.
TahoeDawgZ71 is offline   Reply With Quote
Unread 05-31-2016, 06:43 PM   #8
Not Yet Wild
Club Car
 
Join Date: Mar 2016
Posts: 32
Default Re: Has my speed sensor been discontinued??

Once again I really appreciate the help guys! By the sounds of it I'm not going to waste money on replacing the speed sensor as they don't seem like they are very useful on my model. I read the thread that Joesam linked to, which seems to describe my issues, I didn't remember until I read it that I had an issue getting up my ramps at a steep angle, the cart seemed to just shut down if you didn't hit the ramps with speed and not let off until in the truck. I have six 8v batteries, it didn't say in the thread what the overall pack reading for a good pack should be after standing for several hrs, what each battery should ready under a load for a good/decent battery. Also I've had a few people at the campground suggest new motor brushes... does anyone think there's any truth to that?
Jayts508 is offline   Reply With Quote
Unread 05-31-2016, 06:50 PM   #9
Not Yet Wild
Club Car
 
Join Date: Mar 2016
Posts: 32
Default Re: Has my speed sensor been discontinued??

Forgot to add this to my last post. I know for a fact that I have at least 1 of them big coils but I'll have to take a close look this weekend if I have 2 or not. And if my cart was modified what would it have been modified for and is that a good or a bad thing?
Jayts508 is offline   Reply With Quote
Unread 05-31-2016, 08:54 PM   #10
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,975
Default Re: Has my speed sensor been discontinued??

The coil will be on the driver side solenoid. I think you may have a bad battery from what you are saying. They really show up under heavy load.
mrgolf is offline   Reply With Quote
Reply

Tags
club car speed sensor
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
MCOR? Speed Sensor? Controller? Cart Runs at half speed. Advice, please. Electric Club Car
08 precedent electric speed sensor problem. Cart starts at proper speed then slows . Electric Club Car
Does the speed sensor affect reverse speed? Electric Club Car
ez go pds speed sensor Electric EZGO
Half speed, speed sensor problem?. Electric Club Car


All times are GMT -5. The time now is 03:57 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.