lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-01-2016, 02:26 PM   #1
Not Yet Wild
 
Join Date: Apr 2015
Posts: 18
Default Trouble Installing Club Car Precedent Light Kit

I am installing a Club Car Precedent Light Kit for a 2008 Club Car Precedent. I have installed the front and rear lights and hooked up the fuse wire to the #4 battery and I have no lights, front or rear. Can't figure out what I am doing wrong. Any help will be greatly appreciated.
Michael Reese is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-01-2016, 06:50 PM   #2
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: Trouble Installing Club Car Precedent Light Kit

With so little information let me take a stab at it. You hooked up the red fuse wire but did you hook the black neg wire?
jjance is offline   Reply With Quote
Unread 06-01-2016, 09:02 PM   #3
Gone Wild
Club Car
 
Join Date: Dec 2013
Location: Connecticut
Posts: 240
Default Re: Trouble Installing Club Car Precedent Light Kit

S/N please...??? Just out of curiosity...did your cart come with a factory supplied light harness or was the light harness an add on ? It seems CC stopped supplying a factory harness with the 2008 1/2 (appx. mid year production) model year...
flkeysdude359 is offline   Reply With Quote
Unread 06-01-2016, 09:03 PM   #4
Getting Wild
Club Car
 
Join Date: Apr 2016
Location: Appleton WI
Posts: 83
Default Re: Trouble Installing Club Car Precedent Light Kit

check all the plug connections to the bucket harness and make sure they are tight.

I'm assuming (I know. . . ) that you have 4 x 12v batteries, right? Did you connect the + fused wire and the negative to the same battery?

Did you mount the switch in the dash? You could bypass the switch to rule it out. Just short the two terminals together.

Do you have a voltmeter? If so, check for voltage at the fuse, at the switch, then at the bucket harness.
trainsafe is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Trouble Installing Club Car Precedent Light Kit Electric Club Car
Installing light kit on 1988 Club Car Electric Club Car
Installing Club Car LIGHTS--2007 PRECEDENT Electric Club Car
2004 Club Car Precedent battery trouble Electric Club Car
gas club car, won't crank after installing light switch Gas Club Car


All times are GMT -5. The time now is 04:58 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.