lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-19-2016, 09:59 PM   #1
Not Yet Wild
Club Car
 
Join Date: Jul 2015
Location: Tennessee-Tri-cities
Posts: 7
Default 83 Club Car ds

I had trouble with solenoids.I replaced all 5 solenoids and it ran for about 300 ' and quit.Checked batteries all ok.I drew a diagram when I disassembled it and assembled it the same way it came out.It ran fine for 300' and felt like someone just disconnected the batteries.Thoughts!!!
Paul9938 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-19-2016, 11:10 PM   #2
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,079
Default Re: 83 Club Car ds

If it ran for 300 ft then I'm guessing it was wired up correctly and something else has let go... Can you post some pics of the components
scottyb is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes



All times are GMT -5. The time now is 08:21 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.