lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-23-2016, 06:45 PM   #1
Not Yet Wild
Club Car
 
Join Date: May 2016
Location: Atlanta, GA
Posts: 56
Default Speed and Throttle Issue Troubleshooting. MCOR Issue?

I'm now suddenly experiencing issues with my top speed. When I have the pedal fully pressed, I am experiencing moments of acceleration loss. It's almost like there is a loose cable that is connecting and losing connectivity; however, I have checked all cables and they are all secure. I am experiencing the cart moving fine at full speed, then its like I pulled my foot from the pedal, then fully pressed it again, then removed it, pressed, and so on.

A few days ago I posted about jitters during mid-acceleration and it sounded like I need a new MCOR. Could this also be related to the MCOR (it wasn't doing this new issue at the time of my other post)? This new issue feels more like moments of power loss, where the mid-acceleration issue seemed like jitters from various levels of power (if that makes sense).

Any ideas or suggestions to help me troubleshoot? Or can this definitely be chalked up as needing a new MCOR?
flyons78 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-23-2016, 07:11 PM   #2
Gone Wild
Club Car
 
Join Date: Apr 2014
Location: Oregon City, Or
Posts: 1,941
Default Re: Speed and Throttle Issue Troubleshooting. MCOR Issue?

Try this. With the key off, pump the throttle 20-30 times, then see if your throttle control is better. If there is improvement it will only temporary and another indication that the MCOR is on it's last legs.


.
tag50 is offline   Reply With Quote
Unread 06-23-2016, 07:19 PM   #3
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: Speed and Throttle Issue Troubleshooting. MCOR Issue?

To me it sounds like a problem with your controller. Mine was doing that right before it quit. You might also try changing some settings to try and minimize your problem. I'd start by turning the speed control off. I would also unplug the speed sensor in case it is bad. Next I would decrease the Armature and battery to 300amps just in case your overpowering the motor. And lastly do the old reliable and try pumping the throttle 20-50 times to see if that fixes it.
jjance is offline   Reply With Quote
Unread 06-23-2016, 07:26 PM   #4
Not Yet Wild
Club Car
 
Join Date: May 2016
Location: Atlanta, GA
Posts: 56
Default Re: Speed and Throttle Issue Troubleshooting. MCOR Issue?

Wow, you guys are good! I just tried the pedal pumping and I think the issue is cleared up. I just bought and installed the controller, so I'd like to think it's not failing.

You mentioned the speed sensor... Do I need the speed sensor connected?? If I don't need it, and it does nothing after upgrading my controller, I'd love to just disconnect it.
flyons78 is offline   Reply With Quote
Unread 06-23-2016, 08:02 PM   #5
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: Speed and Throttle Issue Troubleshooting. MCOR Issue?

If you don't want to use the RPM limit you don't need the speed sensor.
jjance is offline   Reply With Quote
Unread 06-23-2016, 08:04 PM   #6
Gone Wild
Club Car
 
Join Date: Apr 2014
Location: Oregon City, Or
Posts: 1,941
Default Re: Speed and Throttle Issue Troubleshooting. MCOR Issue?

Glad to hear it's running better but remember the temporary part. It's only a band-aid not a cure.

I don't know how the speed sensor interfaces with your controller so can't address that.

At this point I'd get in touch with David at http://revolutiongolfcars.com/. He is who I would get the replacement MCOR from and can answer your other questions.


.
tag50 is offline   Reply With Quote
Unread 06-24-2016, 04:44 PM   #7
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: Speed and Throttle Issue Troubleshooting. MCOR Issue?

Flyons78, Here is something you can try. It won't hurt a thing. Once you have gone through the 20-50 pedal pumps, redo the auto throttle calibration. I would be interesting to see if it will clear up some of the throttle problems.
jjance is offline   Reply With Quote
Unread 06-25-2016, 09:10 AM   #8
Not Yet Wild
Club Car
 
Join Date: May 2016
Location: Atlanta, GA
Posts: 56
Default Re: Speed and Throttle Issue Troubleshooting. MCOR Issue?

Quote:
Originally Posted by jjance View Post
Flyons78, Here is something you can try. It won't hurt a thing. Once you have gone through the 20-50 pedal pumps, redo the auto throttle calibration. I would be interesting to see if it will clear up some of the throttle problems.
Awesome! I'll give this a shot. The issue came back this morning (as expected) so I pulled over to do the pedal pump. It cleared the issue up again. So it sounds like the MCOR is definitely failing. However, I'm all for giving the auto throttle calibration a reset. Even if it doesn't help, I'm always interested to learn. I do a search now on how to do this.
flyons78 is offline   Reply With Quote
Unread 06-25-2016, 09:19 AM   #9
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: Speed and Throttle Issue Troubleshooting. MCOR Issue?

Here is the procedure Alltrax sent me. Do it with the car in neutral.

Quote:
Once in the software you will click controller at the very top then clear auto cal. Once the auto cal clears (The bottom left corner of the window will indicate Auto Cal Cleared) you can work the pedal a few times to recalibrate the throttle. After completion you will want to run the cart to see if the problem persists.
jjance is offline   Reply With Quote
Unread 06-25-2016, 10:16 AM   #10
Not Yet Wild
Club Car
 
Join Date: May 2016
Location: Atlanta, GA
Posts: 56
Default Re: Speed and Throttle Issue Troubleshooting. MCOR Issue?

Much appreciated! I will perform this today and I suspect this may help. The reason being, right after I installed the controller I had visitors in town who I was carting around probably right when the controller was still doing the initial calibration. The issues seemed to start right after they left and I was cruising around on the cart solo with much less weight being hauled.

I'll let you know how it goes. Thanks for the help!
flyons78 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
MCOR issue? Electric Club Car
Possible MCOR/Speed sensor issue??? Electric Club Car
MCOR/Throttle linkage issue slowing my groove Electric Club Car
Need help troubleshooting speed issue Electric Club Car
Junk speed controller or solenoid/resistors issue? no "0 speed" instant ~1/2 throttle Columbia ParCar


All times are GMT -5. The time now is 12:34 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.