lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-04-2016, 02:43 PM   #1
Gone Wild
E-Z-GO
 
Join Date: Apr 2012
Location: South Louisiana
Posts: 374
Default My first Club Car (2005 Precedent)

I just picked up this 05 precedent yesterday and know absolutely nothing about club cars. I have built a few ezgo's though. All of the ezgo's were series carts, so going from 4 wires in the Ezgo wiring harness to this is a little intimidating. What I do know about the cart is that it was in a flood. How likely would it be that any of the components are still good? I assume the controller is bad and plan on upgrading it anyways, but kinda hope i can take the motor apart, clean and try to use it for a little while before I upgrade. Also if I am going to use an aftermarket charger can I get rid of the obc? I would appreciate any advice that you can give.
Attached Images
File Type: jpg image.jpg (153.2 KB, 0 views)
Bmatlock00 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-04-2016, 02:44 PM   #2
Gone Wild
E-Z-GO
 
Join Date: Apr 2012
Location: South Louisiana
Posts: 374
Default Re: My first Club Car (2005 Precedent)

Under the seat
Attached Images
File Type: jpg image.jpg (183.1 KB, 0 views)
Bmatlock00 is offline   Reply With Quote
Unread 07-04-2016, 03:42 PM   #3
Gone Wild
 
Htownblue's Avatar
Club Car
 
Join Date: May 2015
Location: Houston
Posts: 266
Default Re: My first Club Car (2005 Precedent)

First things first....clean the components as best you can. Also look for any loose connections. Examine the tow and run switch from the under side as they tend to rust.
You may or may not have a shorted out system. Take a look at the blue fuse box on the blue wire. Also look at the clear in line fuse which runs in the middle of a yellow wire. See if that is blown. If all connections and fuses are good, you might try hooking up some batteries and see if you blow a fuse or have any issues like that. If not, try it out. See if it runs.
From that point you can trouble shoot as needed.
Htownblue is offline   Reply With Quote
Unread 07-04-2016, 03:43 PM   #4
Gone Wild
 
Htownblue's Avatar
Club Car
 
Join Date: May 2015
Location: Houston
Posts: 266
Default Re: My first Club Car (2005 Precedent)

Also, it looks like your connections on your solenoid are shot. Probably want to replace that too. And those two yellow wires are supposed to connect somewhere fwiw.
Htownblue is offline   Reply With Quote
Unread 07-05-2016, 12:24 PM   #5
Gone Wild
E-Z-GO
 
Join Date: Apr 2012
Location: South Louisiana
Posts: 374
Default Re: My first Club Car (2005 Precedent)

Does anyone know where I can find an oem wiring harness?
Bmatlock00 is offline   Reply With Quote
Unread 07-08-2016, 01:59 PM   #6
Gone Wild
E-Z-GO
 
Join Date: Apr 2012
Location: South Louisiana
Posts: 374
Default Re: My first Club Car (2005 Precedent)

I think it's safe to say this controller is trash!
Attached Images
File Type: jpg image.jpg (200.8 KB, 0 views)
Bmatlock00 is offline   Reply With Quote
Unread 07-08-2016, 08:50 PM   #7
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,730
Default Re: My first Club Car (2005 Precedent)

Controller appears shot, I would pop the motor off and clean the input shaft and regrease and reassemble. If your OBC is shot, you can upgrade to a stand alone DPI charger, which is actually better than the stock system. There is lots of potential in that cart.
jakesnake27 is offline   Reply With Quote
Unread 07-08-2016, 10:12 PM   #8
Gone Wild
 
Htownblue's Avatar
Club Car
 
Join Date: May 2015
Location: Houston
Posts: 266
Default Re: My first Club Car (2005 Precedent)

There are a few vendors that sponsor the site that might sell it. Dave at Revolution or Scotty B might have the hook up as well. Both would set you straight.
Htownblue is offline   Reply With Quote
Unread 07-08-2016, 10:34 PM   #9
Epb
Gone Wild
Club Car
 
Join Date: Mar 2012
Location: Katy, Tx
Posts: 1,019
Default Re: My first Club Car (2005 Precedent)

You can eliminate obc and get a dpi. Contact revolution golf carts a site sponsor he will hook u up. Also, look into a xct controller if thatworks fir your cart. You can test motor with a 12v battery charger.
Epb is offline   Reply With Quote
Unread 07-22-2017, 02:26 AM   #10
Gone Wild
E-Z-GO
 
Join Date: Apr 2012
Location: South Louisiana
Posts: 374
Default Re: My first Club Car (2005 Precedent)

I got the cart running not long after I got it, I am finally getting around to doing the cosmetics. Here is the cart as it sits now. Just waiting on rear seat and front seat covers.
Attached Images
File Type: jpg IMG_4244.jpg (163.0 KB, 0 views)
Bmatlock00 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2005 Club car precedent gas gauge Gas Club Car
2005 Club Car Precedent will not go Electric Club Car
2005 Club Car Precedent only 13 mph top speed Gas Club Car
2005 Club Car Precedent won't go Electric Club Car
2005 precedent club car Electric Club Car


All times are GMT -5. The time now is 01:50 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.