lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-08-2016, 05:46 PM   #1
Getting Wild
Club Car
 
Join Date: Jun 2014
Location: Motown
Posts: 145
Talking MCOR not working... wait, now it is

mcor1 on 03 dc-iq was giving me fits and jerky starts
pedal half down it would lunge, a little more pedal it would lunge again into a higher speed
it was really bad with 500 lbs of water in the bag well for watering trees during the drought were having
was looking at $160 to get the mcor4 and conversion kit and then i read marshred's thread on taking one apart to fix it

removed the mcor1 and bench tested it with my harbor fright freebie multimeter
one pot read 1.03 to 7.55: smooth up and down, the other pot read 7.59 to 1.03: smooth up and down
a little out of spec but nothing bad, especially when you consider my multimeter quality
the micro switch works fine too
so i throw everything back together and it works fine, smooth acceleration up to 15 mph

so... maybe a bad plug connection?
or 'stuff' in the mcor that got knocked loose?
who knows, it works and i saved $160.

water truck ho

_ogre is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-08-2016, 08:45 PM   #2
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,272
Default Re: MCOR not working... wait, now it is

Hey glad you got it going smoothly...
jakesnake27 is offline   Reply With Quote
Unread 07-08-2016, 10:15 PM   #3
Epb
Gone Wild
Club Car
 
Join Date: Mar 2012
Location: Katy, Tx
Posts: 1,019
Default Re: MCOR not working... wait, now it is

So everything us fine? Good! I wish that drought was here!!had enough rain for a year IMO.
Epb is offline   Reply With Quote
Unread 07-09-2016, 11:04 AM   #4
Gone Wild
 
Fairtax4me's Avatar
Club Car
 
Join Date: Dec 2015
Location: Charlottesburg Va
Posts: 155
Default Re: MCOR not working... wait, now it is

Yes, it seems common for the connectors on the MCOR to get some minor varnish or dirt in them. Unplug them both, clean with contact cleaner and blow it dry with compressed air and that usually takes care of it.
Fairtax4me is offline   Reply With Quote
Unread 07-10-2016, 11:38 AM   #5
Getting Wild
Club Car
 
Join Date: Jun 2014
Location: Motown
Posts: 145
Default Re: MCOR not working... wait, now it is

i had a heck of a time getting the plugs out
finally used my compressor to blow the dirt out of the lock tabs, both plugs came right out after that
seals and plugs looked good, nothing noticeable in either plug
i sprayed wd40 in both plugs and blew them out again

i didn't disassemble the mcor, just pulled it out, bench tested and re-installed it
probably a tad bit of corrosion in the potentiometer plug
i guess those electrons are pretty sensitive


ironic that texas is flooding and michigan is dry in june
friday we finally got rain, about 2'' in an hour
72,000 people in mi without power on friday, luckily not me
_ogre is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Can a new controller wait? Electric EZGO
Club Car MCOR II to MCOR 4 Upgrade - Removing Pivot Rod? Electric Club Car
Wait for it........ Announcements


All times are GMT -5. The time now is 03:39 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.