lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-09-2016, 03:24 PM   #1
Not Yet Wild
 
Join Date: Mar 2016
Posts: 4
Default Club car DS died; batteries ok

I have a 2004 club car DS / IQ. It would be running at full power then suddenly lose power and drive very slowly for a brief period then pick back up to full speed. Then that same day it died. As suggested by a few people on this forum, I got a voltage meter and checked each battery.

They all checked out ok. A friend had heard there is a fuse that can blow that may be the issue. Has anyone heard of that? If so, any idea where this fuse is?

Would anyone have any other suggestions what to do since my batteries appear to be ok?

Thanks in advance!
kruton is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-09-2016, 05:28 PM   #2
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,444
Default Re: Club car DS died; batteries ok

Check every connection of the power cables. They can crode and loose connection, sometimes you can not see it inside the cable look for stiff cables, check the motor cables also.
mrgolf is offline   Reply With Quote
Unread 07-09-2016, 05:52 PM   #3
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HILLS FL
Posts: 11,159
Default Re: Club car DS died; batteries ok

Quote:
Originally Posted by kruton View Post
I have a 2004 club car DS / IQ. It would be running at full power then suddenly lose power and drive very slowly for a brief period then pick back up to full speed. Then that same day it died. As suggested by a few people on this forum, I got a voltage meter and checked each battery.

They all checked out ok. A friend had heard there is a fuse that can blow that may be the issue. Has anyone heard of that? If so, any idea where this fuse is?

Would anyone have any other suggestions what to do since my batteries appear to be ok?

Thanks in advance!
there is a fuse by the charger receptacle
if it were blown cart will not go

what is your pack voltage ?
crash test dummy is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
88 club car died Electric Club Car
My 84 YO Mothers '91 Club Car Died Gas Club Car
1996 TXT just died... but batteries full Electric EZGO
'85 Club Car Died Electric Club Car
Electric Club Car Died - HELP Electric Club Car


All times are GMT -5. The time now is 07:22 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.