lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-19-2016, 11:57 AM   #1
Not Yet Wild
 
Join Date: Jun 2013
Posts: 5
Default I think i broke it?!?!?!

hey guy's, so I have a 95 club car DS 36V. I was pulling my jetski with my cart the other day, when I heard a "click". after which the cart wouldn't move forward or back at all. I let it sit for a few hours thinking I may have over heated or over stressed the motor or controller. after which it very very very slowly moved forward for about 10' then stopped.

I checked all my battries - GOOD

I checked battery connections - GOOD

I checked fuses - GOOD

I checked the solenoid - "GOOD" it clicks when pedal is pushed.

now I'm stumped and don't know what or how to move forward to get it to work again.

any help is a great plus.
pokets42 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-19-2016, 01:11 PM   #2
Gone Wild
 
NCPW's Avatar
Club Car
 
Join Date: Sep 2015
Location: North Carolina
Posts: 346
Default Re: I think i broke it?!?!?!

I would check the Vglide. You probably melted it.
NCPW is online now   Reply With Quote
Unread 07-19-2016, 02:29 PM   #3
Not Yet Wild
 
Join Date: Jun 2013
Posts: 5
Default Re: I think i broke it?!?!?!

I pulled the V Glide out. here a few pics of it. How do I test it and or what should I be looking for that may be bad on it???
Attached Images
File Type: jpg 20160719_140551.jpg (257.0 KB, 0 views)
File Type: jpg 20160719_140540.jpg (218.5 KB, 0 views)
pokets42 is offline   Reply With Quote
Unread 07-19-2016, 02:47 PM   #4
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 6,461
Default Re: I think i broke it?!?!?!

This is usually a solenoid failure. Those solenoids on this system are notorious for clicking but not making an internal connection. You can temporarily bypass the solenoid by laying the ball end of a ball peen hammer between the two large posts of the solenoid. If the cart runs with the jumper in place, replace the solenoid.
TahoeDawgZ71 is offline   Reply With Quote
Unread 07-19-2016, 02:53 PM   #5
Gone Wild
Club Car
 
Join Date: Apr 2014
Location: Oregon City, Or
Posts: 1,559
Default Re: I think i broke it?!?!?!

OK, I'm confused. A 48volt multi-step on a 36volt cart???


.
tag50 is offline   Reply With Quote
Unread 07-19-2016, 03:57 PM   #6
Gone Wild
 
NCPW's Avatar
Club Car
 
Join Date: Sep 2015
Location: North Carolina
Posts: 346
Default Re: I think i broke it?!?!?!

Quote:
Originally Posted by tag50 View Post
OK, I'm confused. A 48volt multi-step on a 36volt cart???


.
???



Quote:
hey guy's, so I have a 95 club car DS 36V
NCPW is online now   Reply With Quote
Unread 07-19-2016, 04:18 PM   #7
Not Yet Wild
 
Join Date: Jun 2013
Posts: 5
Default Re: I think i broke it?!?!?!

that's my bad on the 36V. I just doubled checked the batteries and they are 8V and there are 6 of them = 48V. sorry for the confusion.
pokets42 is offline   Reply With Quote
Unread 07-19-2016, 10:43 PM   #8
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 6,461
Default Re: I think i broke it?!?!?!

Quote:
Originally Posted by tag50 View Post
OK, I'm confused. A 48volt multi-step on a 36volt cart???


.
Good eye. I didn't notice that at first.
TahoeDawgZ71 is offline   Reply With Quote
Unread 07-19-2016, 10:45 PM   #9
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 6,461
Default Re: I think i broke it?!?!?!

What's the serial number for your cart? There are 2 48v series systems in 1995. The serial number will help me identify it before I help with your diagnosis.
TahoeDawgZ71 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
96 club car, broke geardrive? Broke outputshaft Electric Club Car
Broke txt Electric EZGO
Broke rod :( Gas EZGO
94 cc I BROKE SOMETHING! Electric Club Car
Broke something again!!!!! Lifted Golf Carts


All times are GMT -5. The time now is 01:06 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.