lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-11-2016, 04:25 PM   #11
Gone Wild
Club Car
 
Join Date: Sep 2012
Location: Alberta - Canada
Posts: 904
Default Re: Dead cc precedent

It still sounds to me like a battery is not part of the charging / driving circuit - did you measure the FULL voltage (very first post to very last post) on your pack per Teecro
Quote:
If you got a reading of 8.3 volts from each battery and your only getting a reading of 42 volts then something is dead wrong as you should be reading 49.8 volts across main pack (-) to (+) so you should double check that all batteries are connected in series meaning it should look something like this.

---[- B1 +]---[- B2 +]---[- B3 +]---[- B4 +]---[- B5 +]---[- B6 +]---

Sounds like a battery is in backwards...
joesam is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Reply

Tags
clicking, melted cable, new ba8
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
05 precedent completly dead Electric Club Car
05' Precedent dead Electric Club Car
precedent dead in the garage Electric Club Car
2005 club car precedent dead Electric Club Car
05 Precedent - Dead - Charger won't come on Electric Club Car


All times are GMT -5. The time now is 01:06 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.