lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-16-2016, 11:12 AM   #1
Gone Wild
 
55BigBlock's Avatar
Club Car
 
Join Date: Feb 2013
Location: NC/SC
Posts: 640
Default 2000.5 CC DS Series won't charge

I have a 2000.5 CC DS 48V Series cart with a 22110 Powerdrive charger. The cart was wrecked and been sitting for about 10 years. I replaced the front suspension and installed some batteries and it took right off. I then tried plugging in the charger.......nothing. I followed TahoeDawg's tutorial and determined the grey wire is broken in the socket. I then put a jumper from the grey wire to the green wire inside the charger coming from that corresponding pin in the socket. Based on the test in paragraph 4, my OBC is communicating. When I plug the charger in it hums really loud and there is no meter movement. I thought I saw a whisp of smoke possibly coming from the bridge rectifier. I'm just before ordering a new charging socket and a rectifier rebuild kit for the charger. Am I missing something???? Please chime in. Thanks in advance.
55BigBlock is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-16-2016, 12:55 PM   #2
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,360
Default Re: 2000.5 CC DS Series won't charge

Quote:
Originally Posted by 55BigBlock View Post
I have a 2000.5 CC DS 48V Series cart with a 22110 Powerdrive charger. The cart was wrecked and been sitting for about 10 years. I replaced the front suspension and installed some batteries and it took right off. I then tried plugging in the charger.......nothing. I followed TahoeDawg's tutorial and determined the grey wire is broken in the socket. I then put a jumper from the grey wire to the green wire inside the charger coming from that corresponding pin in the socket. Based on the test in paragraph 4, my OBC is communicating. When I plug the charger in it hums really loud and there is no meter movement. I thought I saw a whisp of smoke possibly coming from the bridge rectifier. I'm just before ordering a new charging socket and a rectifier rebuild kit for the charger. Am I missing something???? Please chime in. Thanks in advance.
Call me, we'll talk about it. 706-836-7210
TahoeDawgZ71 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2000 48v series motor Golf Carts and Parts
2000 txt standard series will not run Electric EZGO
2000 Club Car DS 48v series. Electric Club Car
2000 Club Car Ds Series 48v Electric Club Car
2000 series ezgo needs help Electric EZGO


All times are GMT -5. The time now is 11:06 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.