lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-19-2016, 08:44 PM   #1
Gone Wild
Club Car
 
Join Date: Oct 2008
Location: East Texas
Posts: 299
Default 2012 Excel Precedent, XCT 400, Admiral MOT-A2 Issues

I just got this cart about 3 weeks ago. It was built by the dealer I work with locally. It is a 2012 Precedent Excel model with an XCT 400, 400 Amp solenoid, 4 ga wires, 6x8 volt batteries, 6" Allsports lift with 23" tires and an Admiral MOT-A2 motor. The cart ran great for a week or so, very fast and good torque. Then it started having an intermittent problem in reverse. Sometimes you could depress the go pedal all the way to the floor with no movement. The reverse buzzer comes on and the solenoid clicks. Then all of a sudden it would try to move a bit and stop. Then sometimes it would take off at full speed. That intermittent problem is now full time. I talked to Alltrax last week and went through troubleshooting with them. WE determined that the controller was at fault and they sent me another unit. I installed it today and still have the same issues.

I will run the monitor program tomorrow and record it to send to Alltrax. But in the meantime has anyone seen anything like this?
basshawk84 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-21-2016, 07:42 PM   #2
Gone Wild
 
Join Date: Mar 2016
Posts: 264
Default

Yes, my cart acted like it had a seizure.

Go into the software and turn off the speed sensor data, I think it's speed limit radio button. It all the way at the bottom.

Then save and upload to the controller (key part that people forget).

See if it's any better.


Sent from my iPhone using Tapatalk
Patela2oh is offline   Reply With Quote
Unread 08-22-2016, 04:47 AM   #3
Gone Wild
Club Car
 
Join Date: Oct 2008
Location: East Texas
Posts: 299
Default Re: 2012 Excel Precedent, XCT 400, Admiral MOT-A2 Issues

thanks, I'll give it a shot.
basshawk84 is offline   Reply With Quote
Unread 08-22-2016, 06:27 AM   #4
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: 2012 Excel Precedent, XCT 400, Admiral MOT-A2 Issues

Plug your computer in and check your MCOR. Make sure the throttle sw radio button is active and you're getting 100% throttle. Make sure the HPD is not active. Or just take it back to the dealer
jjance is offline   Reply With Quote
Unread 08-22-2016, 07:57 AM   #5
Gone Wild
Club Car
 
Join Date: Oct 2008
Location: East Texas
Posts: 299
Default Re: 2012 Excel Precedent, XCT 400, Admiral MOT-A2 Issues

Yep, did all that before replacing the controller. MCOR output is reading fine all the way to 100%.
basshawk84 is offline   Reply With Quote
Unread 08-22-2016, 10:15 AM   #6
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 62,702
Default Re: 2012 Excel Precedent, XCT 400, Admiral MOT-A2 Issues

Uncheck the control motor rpm box, see if that 'fixes' it. If yes replace speed sensor or speed sensor wiring. The Admiral motor may have a bad sensor. It's not unheard of. Every dealer should have a supply of replacements. One sensor fits all.
scottyb is offline   Reply With Quote
Unread 08-22-2016, 10:23 AM   #7
Gone Wild
Club Car
 
Join Date: Oct 2008
Location: East Texas
Posts: 299
Default Re: 2012 Excel Precedent, XCT 400, Admiral MOT-A2 Issues

I went into the software and unchecked Enable Speed Limit and it works fine with the exception that it is now about 5mph slower. So I'm guessing that the controller thinks its an 8 pole magnet instead of a 4 pole in the sensor.
basshawk84 is offline   Reply With Quote
Unread 08-22-2016, 11:53 AM   #8
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 62,702
Default Re: 2012 Excel Precedent, XCT 400, Admiral MOT-A2 Issues

Quote:
Originally Posted by basshawk84 View Post
I went into the software and unchecked Enable Speed Limit and it works fine with the exception that it is now about 5mph slower. So I'm guessing that the controller thinks its an 8 pole magnet instead of a 4 pole in the sensor.
I believe you just confirmed the speed sensor is bad because now the controller is not looking at that information and the cart runs fine, call the dealer and ask him to replace it.
scottyb is offline   Reply With Quote
Unread 08-22-2016, 11:53 AM   #9
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 62,702
Default Re: 2012 Excel Precedent, XCT 400, Admiral MOT-A2 Issues

Quote:
Originally Posted by basshawk84 View Post
I went into the software and unchecked Enable Speed Limit and it works fine with the exception that it is now about 5mph slower. So I'm guessing that the controller thinks its an 8 pole magnet instead of a 4 pole in the sensor.
I believe you just confirmed the speed sensor is bad because now the controller is not looking at that information and the cart runs fine, call the dealer and ask him to replace it. Keep us posted
scottyb is offline   Reply With Quote
Unread 08-22-2016, 11:57 AM   #10
Gone Wild
Club Car
 
Join Date: Oct 2008
Location: East Texas
Posts: 299
Default Re: 2012 Excel Precedent, XCT 400, Admiral MOT-A2 Issues

Called the dealer and have a sensor on order. I'll report back after I get it replaced. Thanks for the help everyone!!
basshawk84 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Should I buy Precedent I2 Excel 2012 $2,000 Electric Club Car
2012 DS surging issues Electric Club Car
2012 precedent Excel controller question Electric Club Car
2010 precedent excel i2 w/excel braking Electric Club Car
Speed Magnet Issues with 2010 CC Precedent i2 Excel Electric Club Car


All times are GMT -5. The time now is 11:40 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.