lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-20-2016, 03:30 PM   #1
Not Yet Wild
Club Car
 
Join Date: Jul 2014
Posts: 2
Default Charging/OBC Problem

When I plug in 2 different chargers (not at the same time) to my 48V DS Series cart the ammeter goes right to 15 Amps until the charger overheats and trips the circuit breaker. The needle doesn't go up and down like it normally does on my other cart when you first plug it in. It just stays at about 15 Amps. My battery voltage is 49.1 volts. Is this a bad OBC? Thanks for any help.
Rayscopes is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-20-2016, 03:39 PM   #2
Gone Wild
 
55BigBlock's Avatar
Club Car
 
Join Date: Feb 2013
Location: NC/SC
Posts: 579
Default Re: Charging/OBC Problem

Welcome, It sounds like you have a bad battery to me. How old are the batteries? Have they been maintained properly? Have you checked the individual battery voltage and compared it to a state of charge chart? 49.1 is only about 60% charged, very low. If the charger was on for a reasonable period of time it should be higher than that. Check the sticky "Everything to do with batteries". I had the same problem when a battery went bad. The charger is struggling because of a bad b battery. Good Luck
55BigBlock is offline   Reply With Quote
Unread 08-20-2016, 04:10 PM   #3
Not Yet Wild
Club Car
 
Join Date: Jul 2014
Posts: 2
Default Re: Charging/OBC Problem

Thanks. Each battery is 8.2V. The batteries are dated 2009. Is that about the useful life?
Rayscopes is offline   Reply With Quote
Unread 08-20-2016, 04:35 PM   #4
Gone Wild
 
55BigBlock's Avatar
Club Car
 
Join Date: Feb 2013
Location: NC/SC
Posts: 579
Default Re: Charging/OBC Problem

Yes you got more than most. I replaced my June 2010 batteries last week and was extremely happy with their longevity. Did you look at the state of charge chart?
55BigBlock is offline   Reply With Quote
Unread 08-20-2016, 06:25 PM   #5
Gone Wild
Club Car
 
Join Date: Oct 2008
Location: East Texas
Posts: 285
Default Re: Charging/OBC Problem

Is it tripping the circuit breaker on the charger? If so, it could be a weak breaker and can be replaced. I had one doe that. It would charge for about 5 minutes then trip. I got a replacement breaker from Tahoedawg at Revolution Golf Carts and still working 18 months later.
basshawk84 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
New Problem, over charging Electric Club Car
charging problem Gas EZGO
ez go charging problem Electric EZGO
Charging problem Gas EZGO
charging problem? Gas Club Car


All times are GMT -5. The time now is 05:42 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.