lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-12-2016, 09:40 PM   #31
Not Yet Wild
 
Join Date: Jan 2012
Posts: 36
Default Re: Help please !!

Well the 0v and the 4v batteries won't hold a charge. They keep going down, once I get them up to 7.5 volts..
gatorbait154 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-12-2016, 09:53 PM   #32
Not Yet Wild
 
Hawkeye00's Avatar
Club Car
 
Join Date: Jul 2016
Location: Middleburg, FL
Posts: 31
Default Re: Help please !!

Questions? What is the red cable coming off the top battery towards the back of the cart and the second black cable coming off the bottom battery towards the back of the cart??
Hawkeye00 is offline   Reply With Quote
Unread 09-12-2016, 09:54 PM   #33
Gone Wild
 
teecro's Avatar
Club Car
 
Join Date: Jun 2014
Location: Sunset Bay, TN
Posts: 2,061
Default Re: Help please !!

Quote:
Originally Posted by gatorbait154 View Post
Well the 0v and the 4v batteries won't hold a charge. They keep going down, once I get them up to 7.5 volts..
While I truly suspect they are toast keep in mind that you are only surface charging them so they will fall rapidly once the 12 volt "perk" charger is removed.... Keep trying to build the voltage in each battery so that the total pack is well over 42 volts this hopefully should allow the 48 volt charger to kick in. This may bring your batteries back up enough to be useful again once a deep high amp charge can flow into them for hours on end...
teecro is offline   Reply With Quote
Unread 10-03-2016, 08:18 PM   #34
Not Yet Wild
 
Join Date: Jan 2012
Posts: 36
Default Re: Help please !!

Ok guys, I have 5 new batteries and the sixth is reading 7.4 volts. Plug charger in, hear a click and then nothing. No humming and no charging... I'm at a loss for words. This cart is really working on my patience..
gatorbait154 is offline   Reply With Quote
Unread 10-06-2016, 08:04 AM   #35
Gone Wild
 
teecro's Avatar
Club Car
 
Join Date: Jun 2014
Location: Sunset Bay, TN
Posts: 2,061
Default Re: Help please !!

Quote:
Originally Posted by gatorbait154 View Post
Ok guys, I have 5 new batteries and the sixth is reading 7.4 volts. Plug charger in, hear a click and then nothing. No humming and no charging... I'm at a loss for words. This cart is really working on my patience..
Let's try jumpering the charger as pictured to test the circuit breaker on the AC side as well as the charging relay.

Curious what did you replace/purchase all but one battery?
Attached Images
File Type: jpg Charger Jumper.jpg (188.4 KB, 0 views)
teecro is offline   Reply With Quote
Unread 10-06-2016, 08:31 AM   #36
Not Yet Wild
 
Join Date: Jan 2012
Posts: 36
Default Re: Help please !!

I have to give a plug to tahoedogz71 for spending 30 minutes on the phone with me and helping me trouble shoot my cart issues. Mcor is bad and the relay on my charger is bad also. I ordered the parts from him and hope to have it running soon..

As far as the batteries, I will replace the remaining battery next month. Thanks for all of the replies..
gatorbait154 is offline   Reply With Quote
Unread 10-06-2016, 09:45 AM   #37
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2016
Location: Bel Air, MD
Posts: 52
Default Re: Help please !!

to measure your battery pack voltage, measure the battery pack at the MAIN positive and MAIN negative, they are the 2 wires that go from the battery pack to the controller.
bird6246 is offline   Reply With Quote
Unread 10-06-2016, 09:57 AM   #38
Not Yet Wild
 
Join Date: Jan 2012
Posts: 36
Default Re: Help please !!

Battery pack voltage is good. I have 50v across the pack.
gatorbait154 is offline   Reply With Quote
Unread 10-06-2016, 10:34 PM   #39
Gone Wild
 
teecro's Avatar
Club Car
 
Join Date: Jun 2014
Location: Sunset Bay, TN
Posts: 2,061
Default Re: Help please !!

Quote:
Originally Posted by gatorbait154 View Post
I have to give a plug to tahoedogz71 for spending 30 minutes on the phone with me and helping me trouble shoot my cart issues. Mcor is bad and the relay on my charger is bad also. I ordered the parts from him and hope to have it running soon..
Indeed top shelf....
teecro is offline   Reply With Quote
Unread 10-16-2016, 09:16 PM   #40
Getting Wild
E-Z-GO
 
Join Date: Oct 2007
Location: lake city south carolina,29560
Posts: 95
Default Re: Help please !!

I agree ,,top shelf he is
fbryant1 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes



All times are GMT -5. The time now is 06:49 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.