lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-08-2016, 10:58 AM   #1
Not Yet Wild
 
Join Date: Sep 2016
Posts: 1
Default 86 Club Car- NEW Trijan batteries -NOTHING...

Long time reader, 1st time poster :)

This is my first cart, bought it to cruise around in the campgrounds. Cart originally came with Interstate batteries which upon inspection the water levels were 1/2" below the plates and cart will go on flat ground but very sick on even the slightest of inclines- THUS the new Trojan battery purchase-start with a fresh slate and see how it goes.....HOWEVER-

Just installed (6) 6v Trojans last night. Prior to removal took MANY pictures of the routing of all cables and wires.

Installed new batteries and put wiring back EXACTLY as it was PRIOR to old battery removal, now I have battery meter will light up near key switch, but ZERO headlights or movement in forward OR reverse.....

Very frustrated and not sure what avenue to take next?

Any help, feedback or comments would be GREATLY appreciated.
FirstClubCar is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-08-2016, 12:58 PM   #2
Gone Wild
Yamaha
 
Join Date: May 2012
Location: Rio Verde, Az
Posts: 2,667
Default Re: 86 Club Car- NEW Trijan batteries -NOTHING...

Get out your volt meter and measure battery voltages. Whole pack and individual batteries. Something is not hooked up correctly if it worked before the battery replacements.
Volt_Ampere is offline   Reply With Quote
Unread 09-08-2016, 01:34 PM   #3
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 63,337
Default Re: 86 Club Car- NEW Trijan batteries -NOTHING...

First ting I do is look everywhere for the wire I forgot to reconnect. Once found this fixes 99% of these carts.

If the batteries are not in series correctly - the cart may not work. Check the pack overall voltage and check the voltage in the charge receptacle....

If the swap involved any accidental sparks we could be looking for another problem.
scottyb is offline   Reply With Quote
Unread 09-08-2016, 02:16 PM   #4
Gone Wild
Club Car
 
Join Date: Apr 2014
Location: Oregon City, Or
Posts: 1,890
Default Re: 86 Club Car- NEW Trijan batteries -NOTHING...

Also look for battery/batteries oriented wrong. It wouldn't be the first time.

Oops- I was interrupted between typing and posting and Scotty beat me.


.
tag50 is offline   Reply With Quote
Unread 09-08-2016, 07:50 PM   #5
Gone Wild
 
Golf cart guy's Avatar
 
Join Date: May 2015
Location: Central Florida
Posts: 1,235
Default Re: 86 Club Car- NEW Trijan batteries -NOTHING...

If it ran before the battery change but not after.......Its installation error. I cant count how many times someone has told me they took pictures and the batteries are installed correctly, only to walk up, lift the seat and say "that's not hooked up correctly" 5 minute fix.
Golf cart guy is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
02 club car---new batteries Electric Club Car
Club car pd batteries Electric Club Car
Club Car Batteries Electric Club Car
96 club car batteries Electric Club Car
89 DS Club Car without batteries Electric Club Car


All times are GMT -5. The time now is 12:10 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.