lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-14-2016, 07:39 AM   #1
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default 2011 Precedent new batteries won't run

Hello BGW. I have a 2011 Precedent with brand new batteries. It will not run or click or anything. One thing I did notice is when I plug the charger in that the relay in the charger clicks right away. There is no delay. I have no idea what that could mean. Has anyone had this problem before??????
grandpa1 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-14-2016, 08:06 AM   #2
Gone Wild
 
teecro's Avatar
Club Car
 
Join Date: Jun 2014
Location: Sunset Bay, TN
Posts: 2,192
Default Re: 2011 Precedent new batteries won't run

Did it run before the new batteries were installed?
teecro is offline   Reply With Quote
Unread 09-14-2016, 08:31 AM   #3
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,793
Default Re: 2011 Precedent new batteries won't run

If the charger relay clicks immediately when the charger plug is inserted, the charger receptacle is incorrectly connected to the vehicle wiring or the on-board computer has failed.
TahoeDawgZ71 is offline   Reply With Quote
Unread 09-14-2016, 08:43 AM   #4
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default Re: 2011 Precedent new batteries won't run

The charger did work a week ago, but before the new batteries were installed it had the same issue when plugged in the charger. Also when the cart is put in reverse and you switch on the run tow switch it gives one lil beep and that is it. It will not even sound the reverse buzzer continually when put in reverse.
grandpa1 is offline   Reply With Quote
Unread 09-14-2016, 08:54 AM   #5
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,793
Default Re: 2011 Precedent new batteries won't run

Quote:
Originally Posted by grandpa1 View Post
The charger did work a week ago, but before the new batteries were installed it had the same issue when plugged in the charger. Also when the cart is put in reverse and you switch on the run tow switch it gives one lil beep and that is it. It will not even sound the reverse buzzer continually when put in reverse.
This can also be the result of a failed on-board computer.
TahoeDawgZ71 is offline   Reply With Quote
Unread 09-14-2016, 09:54 AM   #6
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default Re: 2011 Precedent new batteries won't run

Ok I will have to ck it out then
grandpa1 is offline   Reply With Quote
Unread 09-14-2016, 10:10 AM   #7
Gone Wild
 
Nsane's Avatar
Club Car
 
Join Date: Jun 2014
Location: Concord, NC
Posts: 267
Default Re: 2011 Precedent new batteries won't run

Read the top post in this form, there is a post how to check your OBC for charging, very easy to do, hope that helps you out.
Nsane is offline   Reply With Quote
Unread 09-14-2016, 10:28 AM   #8
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default Re: 2011 Precedent new batteries won't run

I read it but it doesn't make clear where to hook what up to from what I just read.
grandpa1 is offline   Reply With Quote
Unread 09-14-2016, 03:16 PM   #9
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default Re: 2011 Precedent new batteries won't run

Obc was bad. Thank y'all for the help
grandpa1 is offline   Reply With Quote
Unread 09-14-2016, 08:43 PM   #10
Gone Wild
 
Nsane's Avatar
Club Car
 
Join Date: Jun 2014
Location: Concord, NC
Posts: 267
Default Re: 2011 Precedent new batteries won't run

Glad you got it figured out!
Nsane is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2011 Precedent Batteries Overheating Electric Club Car
2011 Precedent Electric Club Car
F.S. 09 RXV w/2011 Batteries Golf Carts and Parts
New guy here with a 2011 Precedent. I have some ?s Electric Club Car
2011 Precedent Test Post


All times are GMT -5. The time now is 04:50 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.