lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 11-03-2016, 01:14 PM   #1
Getting Wild
 
oldngray's Avatar
Club Car
 
Join Date: May 2009
Location: SW Florida
Posts: 137
Default Clicks but No Go

48V DS, AC0106-987731. 50+ V to Motor, Sel clicks, Reverse Buzzer sounds in Reverse, but wheels to do turn in fwd or reverse.
oldngray is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 11-03-2016, 02:09 PM   #2
Gone Wild
Club Car
 
Join Date: Nov 2012
Posts: 280
Default Re: Clicks but No Go

Have you removed the cable going from the solenoid to the controller/motor and tested what voltage, if any, you get at the solenoid and the main negative battery post? If you get no voltage, your solenoid contacts are bad. If you get voltage, the problem is elsewhere.

What else do you have on your golf cart? Just all stock?
MyCousinVinnie is offline   Reply With Quote
Unread 11-03-2016, 02:58 PM   #3
Getting Wild
 
oldngray's Avatar
Club Car
 
Join Date: May 2009
Location: SW Florida
Posts: 137
Default Re: Clicks but No Go

Will check that and get back here.

Stock cart, used on a small Ranch
oldngray is offline   Reply With Quote
Unread 11-04-2016, 08:24 AM   #4
Getting Wild
 
oldngray's Avatar
Club Car
 
Join Date: May 2009
Location: SW Florida
Posts: 137
Default Re: Clicks but No Go

Quote:
Originally Posted by MyCousinVinnie View Post
Have you removed the cable going from the solenoid to the controller/motor and tested what voltage, if any, you get at the solenoid and the main negative battery post? If you get no voltage, your solenoid contacts are bad. If you get voltage, the problem is elsewhere.

What else do you have on your golf cart? Just all stock?
Have 51V between solenoid and main neg.
oldngray is offline   Reply With Quote
Unread 11-04-2016, 03:37 PM   #5
Getting Wild
 
oldngray's Avatar
Club Car
 
Join Date: May 2009
Location: SW Florida
Posts: 137
Default Re: Clicks but No Go

What we found, white wire attached to the module was loose. Replaced wire and all is good.
Without performing the check suggested above, we probably would not have found this.
Thanks
oldngray is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Clicks but won't go Electric Club Car
G16 clicks but no go Electric Yamaha
solenoid clicks clicks clicks Electric Club Car
G16 clicks but won't run Gas Yamaha
'95 CC just clicks Electric Club Car


All times are GMT -5. The time now is 05:32 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.