lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-26-2016, 03:35 PM   #1
Gone Wild
 
Night life's Avatar
Club Car
 
Join Date: Oct 2014
Location: South Florida
Posts: 213
Default Charger issue

I bought a 2013 Precedent without a charger. It has 1.5 year old Crown batteries but didn't come with a charger. I tried my Powerdrive 3 charger that i use on a 2011 DS (that works perfectly on that cart) and I keep getting a yellow fault light when I un-plug (meaning the charger isn't completing its cycles, correct?)

I read up on it and it looks like possibly resetting my OBC will fix the issue or is at least worth a try?

I plan on getting a DPI charger, and bypassing OBC but It won't be here for 2 weeks or so.

Any other ideas before I try the reset? The charger should work as they are both IQ carts correct?

Thanks, Barry
Night life is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 12-26-2016, 03:47 PM   #2
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: Charger issue

That yellow fault light is probably indicating a bad battery. But do the reset. BTW you'll love the DPI.
jjance is offline   Reply With Quote
Unread 12-26-2016, 03:58 PM   #3
Gone Wild
 
Night life's Avatar
Club Car
 
Join Date: Oct 2014
Location: South Florida
Posts: 213
Default Re: Charger issue

I am going to check the batteries tomorrow. I also found this black wire that looks out of place, any idea?
Night life is offline   Reply With Quote
Unread 12-26-2016, 04:01 PM   #4
Gone Wild
 
Night life's Avatar
Club Car
 
Join Date: Oct 2014
Location: South Florida
Posts: 213
Default Re: Charger issue

Black wire with yellow butt connector?
Attached Images
File Type: jpg IMG_3109.jpg (168.8 KB, 0 views)
Night life is offline   Reply With Quote
Unread 12-26-2016, 04:03 PM   #5
Gone Wild
 
Night life's Avatar
Club Car
 
Join Date: Oct 2014
Location: South Florida
Posts: 213
Default Re: Charger issue

Another angle
Attached Images
File Type: jpg IMG_3108.jpg (152.0 KB, 0 views)
Night life is offline   Reply With Quote
Unread 12-26-2016, 04:36 PM   #6
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: Charger issue

That looks like it might be the neg wire from your charger. Look around that area and see if there is a bullet connector that will plug into it. Does your charger meter go to 15 amps when you charge your cart? If it doesn't that is defiantly the charger wire.
jjance is offline   Reply With Quote
Unread 12-27-2016, 05:24 AM   #7
Gone Wild
 
Night life's Avatar
Club Car
 
Join Date: Oct 2014
Location: South Florida
Posts: 213
Default Re: Charger issue

Quote:
Originally Posted by jjance View Post
That looks like it might be the neg wire from your charger. Look around that area and see if there is a bullet connector that will plug into it. Does your charger meter go to 15 amps when you charge your cart? If it doesn't that is defiantly the charger wire.
I don't see a bullet connector anywhere. Is there a negative cable that should be connected to the pack that is a smaller cable like pictured? There is a smaller red (positive) cable on battery number 1 (or is that 6?) but not other negative cable besides the heavier gauged cables...
Night life is offline   Reply With Quote
Unread 12-27-2016, 06:17 AM   #8
Gone Wild
 
Sergio's Avatar
Club Car
 
Join Date: Sep 2012
Location: Charlotte, NC
Posts: 7,125
Default Re: Charger issue

That is the standard negative accessories connection provided by Club Car.

It would be used by a DC-DC voltage converter.
Sergio is online now   Reply With Quote
Unread 12-27-2016, 06:30 AM   #9
Gone Wild
 
Night life's Avatar
Club Car
 
Join Date: Oct 2014
Location: South Florida
Posts: 213
Default Re: Charger issue

Quote:
Originally Posted by Sergio View Post
That is the standard negative accessories connection provided by Club Car.

It would be used by a DC-DC voltage converter.
Thank you!

I reset my OBC, when I first plugged the charger in the light came on for a second. The charger stayed in the first mode and wouldn't change. I un-plugged it and tried again and it seemed to act normal. It initially came on, did it's test, shut down for a second and started again. We will see if this fixes it.

I ordered the DPI charger today, either way I will be bypassing the OBC and using the new charger. Hopefully my batteries are good, I will test them later!
Night life is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
charger issue Electric EZGO
Charger issue Electric EZGO
TXT charger issue... Electric EZGO
Charger issue Electric Club Car
charger issue Electric Club Car


All times are GMT -5. The time now is 08:50 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.