lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 02-05-2017, 06:04 PM   #1
Not Yet Wild
 
Bubba78's Avatar
 
Join Date: Aug 2015
Posts: 45
Default Battery pack question

Hello everyone.

I have a odd question. When I do a reading on my pack I get only 42 volts. Reading each battery I get 8.5 for each one for a total of 51 volts

Why when I read the entire pack do I only see 42 volts. It would seem when I do my reading I am missing a battery but if that was the case, where one wasn't wired up correctly why would it be charging? Am I missing something here?
Bubba78 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 02-05-2017, 06:14 PM   #2
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 3,242
Default Re: Battery pack question

Change the battery in your volt meter.
mrgolf is offline   Reply With Quote
Unread 02-05-2017, 06:18 PM   #3
Gone Wild
 
Golferdave's Avatar
Club Car
 
Join Date: Dec 2016
Location: Alaska
Posts: 496
Default Re: Battery pack question

Pack reading missed a battery
You have 2 batts hooked up,in parallel (hard to do , but possible)

Your volt meter maxed out at 42
Golferdave is offline   Reply With Quote
Unread 02-05-2017, 06:18 PM   #4
Not Yet Wild
 
Bubba78's Avatar
 
Join Date: Aug 2015
Posts: 45
Default Re: Battery pack question

I thought that too. It's an older Canadian tire meter.
Bubba78 is offline   Reply With Quote
Unread 02-05-2017, 07:45 PM   #5
Gone Wild
 
dundeebarnbuggy's Avatar
Club Car
 
Join Date: Oct 2016
Location: Dundee quebec
Posts: 2,099
Default Re: Battery pack question

Possible you have answered your own question.
dundeebarnbuggy is offline   Reply With Quote
Unread 02-05-2017, 10:02 PM   #6
Gone Wild
 
Night life's Avatar
Club Car
 
Join Date: Oct 2014
Location: South Florida
Posts: 213
Default Re: Battery pack question

Are you sure you are taking the reading from the last battery in the pack?
Night life is offline   Reply With Quote
Unread 02-06-2017, 05:47 PM   #7
Not Yet Wild
 
Bubba78's Avatar
 
Join Date: Aug 2015
Posts: 45
Default Re: Battery pack question

Night Life!

You're 100% right. I was missing a battery. Person that had the cart before me wired up some stuff to the 2nd battery in place, so I was taking my readings from that one on. So once again my fault / Beers fault.

Thanks everyone for the help! :/
Bubba78 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Question on Effect of Cold on Battery Pack Electric EZGO
Battery voltage question. Pack vs ind. Electric Club Car
Switching lights from battery pack to stand alone battery question Electric EZGO
Battery Pack Guage Question. Electric Club Car
Battery Pack Question Electric EZGO


All times are GMT -5. The time now is 10:42 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.