lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 02-10-2017, 03:18 PM   #1
Not Yet Wild
 
Join Date: Feb 2017
Posts: 4
Default Club car not running after being stored

Hey all, new to the forum!

I have an 84 club car that I just took out of storage. It was being stored indoors for 3 years. i took out the batteries before storing it and it ran great before it was in storage.

Just took it out, put all new batteries in it, and it didn't run. I changed out the main solenoid, still nothing.

I hear clicking from all solenoids, and even pulled the micro switches and checked those, all seem to be operational.

I'm completely stumped. Any thoughts on what I should be testing?

Much appreciation,

Steve
Ssjyellowclubcar is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 02-10-2017, 03:20 PM   #2
Gone Wild
Club Car
 
Join Date: Jul 2016
Location: Ma
Posts: 425
Default Re: Club car not running after being stored

Welcome to BGW. Are the new batteries fully charged?
2016CTD is offline   Reply With Quote
Unread 02-10-2017, 03:24 PM   #3
Not Yet Wild
 
Join Date: Feb 2017
Posts: 4
Default Re: Club car not running after being stored

Thanks! Yes, all are charged
Ssjyellowclubcar is offline   Reply With Quote
Unread 02-11-2017, 01:11 PM   #4
revolutiongolfcars.com
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 9,641
Default Re: Club car not running after being stored

Just because the solenoids are clicking doesn't mean they're working. After sitting in storage for that long, and considering the failure rate of those 8016 solenoids, it wouldn't be a bad idea to replace them.
TahoeDawgZ71 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Maintenance while stored for 3 months Electric Yamaha
97 club car running hot Gas Club Car
Battery to be stored Electric EZGO
EZ-GO stored is it dead ? Electric EZGO
Cart stored now its not working Electric EZGO


All times are GMT -5. The time now is 12:56 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.