lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-04-2017, 04:25 PM   #1
Gone Wild
 
yamahaguy97's Avatar
Yamaha
 
Join Date: Jan 2016
Location: FL
Posts: 904
Default Immediate speed loss

Hey,

First some details about the cart. It's a 2007 DS villager 6 cart with 8 6v batteries. Sepex controller, OBC Mcor. It has new batteries. The issue is when you accelerate it goes pretty fast for a second or two then immediately goes to a crawl. I'm talking around 2-3 mph. If you release the pedal and wait a second, it does the same thing- fast take off for a second, then down to a crawl almost immediately.

I suspect things like the mcor and speed sensor, but club car guys please let me know if there is anything else to check into
yamahaguy97 is online now   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-04-2017, 04:32 PM   #2
Gone Wild
Club Car
 
Join Date: Sep 2015
Location: Cincinnati, Ohio
Posts: 1,354
Default Re: Immediate speed loss

Sounds like a speed sensor to me....
Dave at Revolution should chime in shortly (unless he's working late)
Kashmir is offline   Reply With Quote
Unread 04-04-2017, 04:36 PM   #3
Gone Wild
 
yamahaguy97's Avatar
Yamaha
 
Join Date: Jan 2016
Location: FL
Posts: 904
Default Re: Immediate speed loss

Thank you sir
yamahaguy97 is online now   Reply With Quote
Unread 04-04-2017, 05:59 PM   #4
Gone Wild
Yamaha
 
Join Date: May 2012
Location: Rio Verde, Az
Posts: 2,668
Default Re: Immediate speed loss

Does sound like speed sensor has failed.
Volt_Ampere is offline   Reply With Quote
Unread 04-04-2017, 08:07 PM   #5
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,788
Default Re: Immediate speed loss

It's either the speed sensor or the 10 amp circuit breaker next to the tow/run switch. If you have a Curtis handset to scan the car with it'll tell you for sure. It'll say SPEED SENSOR FAULT or MAIN BREAKER OPEN. Both issues will cause the same problem. If it's a speed sensor, it'll fail the speed sensor test. If it's a breaker, it will still pass the speed sensor test. Try the sensor test in the Sticky section of this forum to narrow it down. IQ plus vehicles like yours will use the 1027049701 ADC/AMD speed sensor, the same as new model IQ/Excel Precedents. Don't buy Chinese crap on eBay. Buy a good one, or buy 17 spares.
TahoeDawgZ71 is offline   Reply With Quote
Unread 04-04-2017, 08:08 PM   #6
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,788
Default Re: Immediate speed loss

Quote:
Originally Posted by Kashmir View Post
Dave at Revolution should chime in shortly (unless he's working late)
Working on a 12 pack.
TahoeDawgZ71 is offline   Reply With Quote
Unread 04-04-2017, 08:19 PM   #7
Gone Wild
Club Car
 
Join Date: Sep 2015
Location: Cincinnati, Ohio
Posts: 1,354
Default Re: Immediate speed loss

and if you need a speed sensor...Revolution Golf Cars (site sponsor) is THE place to get it.
Best customer service ever!!
Kashmir is offline   Reply With Quote
Unread 04-04-2017, 08:23 PM   #8
Gone Wild
 
yamahaguy97's Avatar
Yamaha
 
Join Date: Jan 2016
Location: FL
Posts: 904
Default Re: Immediate speed loss

Thank you everyone
yamahaguy97 is online now   Reply With Quote
Unread 04-04-2017, 08:29 PM   #9
Gone Wild
 
yamahaguy97's Avatar
Yamaha
 
Join Date: Jan 2016
Location: FL
Posts: 904
Default Re: Immediate speed loss

Now that I think of it, earlier today I was looking at the circuit breaker next to the tow switch. Does it have two wires coming out of it from the back from the harness? Because if I remember right it looks like it cracked off from behind the plate where it is mounted and it was laying down on top of some other wires

I have a feeling now it's not the speed sensor
yamahaguy97 is online now   Reply With Quote
Unread 04-04-2017, 08:31 PM   #10
Gone Wild
 
yamahaguy97's Avatar
Yamaha
 
Join Date: Jan 2016
Location: FL
Posts: 904
Default Re: Immediate speed loss

I did not realize that black square box was a circuit breaker
yamahaguy97 is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Low speed sputtering, at a loss Gas EZGO
Loss of Speed Gas Yamaha
speed loss after 4 seconds Electric Club Car
Loss of speed Electric EZGO
Speed loss Electric Club Car


All times are GMT -5. The time now is 07:04 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.