Buggies Gone Wild Golf Cart Forum

Buggies Gone Wild Golf Cart Forum (http://www.buggiesgonewild.com/)
-   Electric Club Car (http://www.buggiesgonewild.com/electric-club-car/)
-   -   Sluggish Cart (http://www.buggiesgonewild.com/electric-club-car/13029-sluggish-cart.html)

cadbrasher 02-20-2009 05:22 PM

Sluggish Cart
 
I have a 1996 club car (48 volt) cart. I replaced the batteries approx. 1 1/2 years ago and can only get about 18 holes of golf in before the cart gets sluggish and slow. Also the battery light comes on. I use to get between 36m and 45 holes of golf in before this happened. Can anyone advise me as to what the problem my be. I don't think the batteries are the problem. I'm thinking maybe a short or computer problem within the cart. Thanks!

crash12888 02-20-2009 05:52 PM

Re: Sluggish Cart
 
Need to check or have the batteries checked to determine how healthy they are. Individually and as a pack. You might have one bad causing this problem. Can you tell us the maintenance history of the batteries?

cadbrasher 02-20-2009 05:59 PM

Re: Sluggish Cart
 
I normally check the water level in them at least once a week as I play golf 3 and 4 times a week. I keep appropriate water levels and charge cart everytime I come in from golf course. My last batteries lasted 6 years under same conditions. If I need to check batteries, what would you suggest--Taking them into the dealer where I bought them? I know they would have all the proper equipment . Thank you

GLEEMO 02-21-2009 08:40 AM

Re: Sluggish Cart
 
The key here is , when you used to get 36 and 45 holes of use,
What type Old Batteries ? manufacturer/model
What type New Batteries ? manufacturer/model
Are you leaving charger on until it shuts off (do you know how long this is)

Do you have a Voltmeter ?

:sign3: to the Forum

scottyb 02-21-2009 08:43 AM

Re: Sluggish Cart
 
Did you replace the battery cables when you got new batteries? If not high resistance or poor connections could be robbing you of run time. 8)

rusty 02-21-2009 11:46 AM

Re: Sluggish Cart
 
Hello cadbrasher and Welcome to the forum.

cadbrasher 02-21-2009 11:59 AM

Re: Sluggish Cart
 
My old batteries were trojans, and the new ones are also. I charge batteries complete, or until charger cuts off on its own. I did check a couple of days ago, and charger takes about 3 1/2 to 4 hrs to charge. I don't unplug the charger until I use my cart again ( which is almost daily. I do not have a voltmeter. Also all cables have been checked and are tight and in good order. No loose or weak (flexible) connections.

scottyb 02-21-2009 12:22 PM

Re: Sluggish Cart
 
Well if everything is in order and functioning as designed then you have to suspect maybe one weak or bad battery ? Call a service guy with a hydrometer and/or a loadtester to check em out? 8)

GLEEMO 02-21-2009 12:34 PM

Re: Sluggish Cart
 
Do as scottyb says post information on test results back to forum

hbuck1215 02-21-2009 03:27 PM

Re: Sluggish Cart
 
re cart slows down on a incline club car with new 8volt batteries any ideas thanks


All times are GMT -5. The time now is 03:37 PM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.