lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-20-2017, 11:53 PM   #1
Not Yet Wild
Tomberlin
 
Join Date: Jul 2014
Location: Northern California
Posts: 47
Unhappy 2014 w/factory battery gauge, battery warning light not working

Hi All,



I recently bought a very clean 2014 with 6 month old batteries which are in great shape. The cart has a factory installed battery indicator gauge that works perfectly. On this year/model when you first connect the charger to the cart, and after a few seconds, the cart beeps three times and the light is supposed to flash three times (my other 2014 does this correctly) to indicate that correct charging is under way. Unfortunately the light does not illuminate or flash. I replaced the light with a OEM part but still no luck. The dash wiring harness does not look like it's been altered at all and all connections are tight. I'm not sure how to troubleshoot this one. I'll be selling this cart to an older couple (80's) who really like the amber light to guide them and I need to get it fixed.

The charger does work fine and batteries are being fully charged.

Any ideas?

Thank you!!!

Scott
Monterey is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-21-2017, 01:58 AM   #2
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 3,668
Default Re: 2014 w/factory battery gauge, battery warning light not working

If you run the cart until the light comes on to tell you to put cart on charger. You are killing the batteries. You need to put a volt meter on it and tell them to not let the voltage drop below 48 volts before putting it on charge.
mrgolf is offline   Reply With Quote
Unread 07-21-2017, 02:26 AM   #3
Gone Wild
Club Car
 
Join Date: Apr 2015
Location: NorCal
Posts: 708
Default Re: 2014 w/factory battery gauge, battery warning light not working

Quote:
Originally Posted by mrgolf View Post
If you run the cart until the light comes on to tell you to put cart on charger. You are killing the batteries. You need to put a volt meter on it and tell them to not let the voltage drop below 48 volts before putting it on charge.
The light on ERIC systems is a little different.

OP, have you tried swapping the charger to the other cart? At least that would narrow down the problem a little. Also, I heard that the chargers had a 4 year warranty. If it is the charger, that would be good news.
Gregorio is offline   Reply With Quote
Unread 07-21-2017, 07:14 AM   #4
Gone Wild
 
Sergio's Avatar
Club Car
 
Join Date: Sep 2012
Location: Charlotte, NC
Posts: 7,652
Default Re: 2014 w/factory battery gauge, battery warning light not working

The dash light is activated by the Curtis controller in the ERIC system.

Is the Controller sensing the charger being plugged and locking the cart?
Sergio is offline   Reply With Quote
Unread 07-21-2017, 02:20 PM   #5
Not Yet Wild
Tomberlin
 
Join Date: Jul 2014
Location: Northern California
Posts: 47
Default Re: 2014 w/factory battery gauge, battery warning light not working

Quote:
Originally Posted by mrgolf View Post
If you run the cart until the light comes on to tell you to put cart on charger. You are killing the batteries. You need to put a volt meter on it and tell them to not let the voltage drop below 48 volts before putting it on charge.
I agree it is an "idiot" light, in that you shouldn't let it get to this point if possible. The thing is the couple (in their 80's) have had CCs for a long time and like to know that if they do get too low the light will come on telling them it's time to come home. They see that it has a gauge too but would like the light to work and I would too. I don't like selling things that don't work properly.

Scott
Monterey is offline   Reply With Quote
Unread 07-21-2017, 02:24 PM   #6
Not Yet Wild
Tomberlin
 
Join Date: Jul 2014
Location: Northern California
Posts: 47
Default Re: 2014 w/factory battery gauge, battery warning light not working

Quote:
Originally Posted by Gregorio View Post
The light on ERIC systems is a little different.

OP, have you tried swapping the charger to the other cart? At least that would narrow down the problem a little. Also, I heard that the chargers had a 4 year warranty. If it is the charger, that would be good news.
So I did try swapping my ERIC chargers. Both chargers make my "working" cart flash the light and beep. Both chargers will make this "broken light" cart beep but not flash the light. Argh!

Scott
Monterey is offline   Reply With Quote
Unread 07-21-2017, 02:25 PM   #7
Not Yet Wild
Tomberlin
 
Join Date: Jul 2014
Location: Northern California
Posts: 47
Default Re: 2014 w/factory battery gauge, battery warning light not working

Quote:
Originally Posted by Sergio View Post
The dash light is activated by the Curtis controller in the ERIC system.

Is the Controller sensing the charger being plugged and locking the cart?
Great idea to check and I did. Both carts sense both chargers being plugged in and do lock the carts.

Scott
Monterey is offline   Reply With Quote
Unread 07-21-2017, 02:27 PM   #8
Gone Wild
Club Car
 
Join Date: Apr 2015
Location: NorCal
Posts: 708
Default Re: 2014 w/factory battery gauge, battery warning light not working

Well, the good news is that you have narrowed it down to the cart and not the charger. I'm not familiar with the ERIC system on the newer carts but have you at least tried to make sure all the connections to the controller are solid? No loose pins?

I wish I could be more help. I agree with you on selling things that are not right especially to people of that age. Kudos to you for persisting.
Gregorio is offline   Reply With Quote
Unread 07-21-2017, 02:33 PM   #9
Not Yet Wild
Tomberlin
 
Join Date: Jul 2014
Location: Northern California
Posts: 47
Default Re: 2014 w/factory battery gauge, battery warning light not working

I have to admit that I'm not that familiar with the 2014 models and haven't even touched a controller on them. I can check out the connections if you can point me in the right direction. My experience with Precedents is pretty much from 2008 models up through 2012s.

Scott
Monterey is offline   Reply With Quote
Unread 07-22-2017, 10:27 AM   #10
Not Yet Wild
Tomberlin
 
Join Date: Jul 2014
Location: Northern California
Posts: 47
Default Re: 2014 w/factory battery gauge, battery warning light not working

Is it possible that the addition of the factory gauge prevents the battery warning light from flashing during the charging start process? I have 2 2014s. One with the factory gauge and one without. The cart without flashes its warning light when starting to charge and the one with the factory gauge does not flash. I wonder if this is normal?
Monterey is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Battery warning light Electric Club Car
Battery Warning Light Electric Club Car
Battery warning light Electric Club Car
Battery Warning Light - On and Off Electric Club Car
Battery warning light Electric Club Car


All times are GMT -5. The time now is 03:59 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.