lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-07-2017, 09:19 PM   #1
Not Yet Wild
 
tanman's Avatar
Club Car
 
Join Date: Nov 2016
Location: NJ
Posts: 11
Default Ignition got wet!

Hi today with all the rain my ignition got wet on my 2011 Club Car Precedent. Voltmeter gauge is staying lit even with the key off and the cart will not move now. I have a 500 alltrack controller on it and a 10 horse motor I disconnected the battery right now hoping that if it dries out everything would be fine. Your thoughts or advice would be greatly appreciated thanks

Sent from my SM-N920V using Tapatalk
tanman is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-07-2017, 09:21 PM   #2
Gone Wild
 
LukeL's Avatar
Yamaha
 
Join Date: Jun 2017
Location: Savannah, GA
Posts: 4,929
Default Re: Ignition got wet!

Happened to me once on an EZ GO. It dried out and started working a few hours later.

Water usually gets in it and makes contact, keeping it on.


Club Car DS Driverís Club #59
LukeL is offline   Reply With Quote
Unread 08-07-2017, 09:34 PM   #3
MOD of all BS!
 
NoleFan4Ever's Avatar
Club Car
 
Join Date: Sep 2011
Location: Florida
Posts: 13,006
Default Re: Ignition got wet!

Quote:
Originally Posted by tanman View Post
Hi today with all the rain my ignition got wet on my 2011 Club Car Precedent. Voltmeter gauge is staying lit even with the key off and the cart will not move now. I have a 500 alltrack controller on it and a 10 horse motor I disconnected the battery right now hoping that if it dries out everything would be fine. Your thoughts or advice would be greatly appreciated thanks
When you say ignition you are referring to the key switch? If so, place Tow/Run switch into tow, remove the cable as you did and then pull the igniting switch out the dash. Take a picture before you unwire it and then use a blow drier set to "COOL", not hot, set the switch in front of it and let it blow for an hour or more. You need to completely dry it out and if it was anything other than water (soda, beer, tea, etc.) then get you a can of Electri-Clean or Co-Contact cleaner and clean the switch out.
NoleFan4Ever is offline   Reply With Quote
Unread 08-07-2017, 09:38 PM   #4
Not Yet Wild
 
tanman's Avatar
Club Car
 
Join Date: Nov 2016
Location: NJ
Posts: 11
Default Re: Ignition got wet!

Quote:
Originally Posted by NoleFan4Ever View Post
When you say ignition you are referring to the key switch? If so, place Tow/Run switch into tow, remove the cable as you did and then pull the igniting switch out the dash. Take a picture before you unwire it and then use a blow drier set to "COOL", not hot, set the switch in front of it and let it blow for an hour or more. You need to completely dry it out and if it was anything other than water (soda, beer, tea, etc.) then get you a can of Electri-Clean or Co-Contact cleaner and clean the switch out.
Yes referring to the key switch. I will do that first thing in the morning. I was just worrying I may have shorted the controller out. Thanks I'll keep you posted

Sent from my SM-N920V using Tapatalk
tanman is offline   Reply With Quote
Unread 08-08-2017, 06:15 PM   #5
Not Yet Wild
 
tanman's Avatar
Club Car
 
Join Date: Nov 2016
Location: NJ
Posts: 11
Default Re: Ignition got wet!

Thanks just a follow-up everything went good today. Everything dried out everything's working fine.thanks.

Sent from my SM-N920V using Tapatalk
tanman is offline   Reply With Quote
Unread 08-08-2017, 06:17 PM   #6
MOD of all BS!
 
NoleFan4Ever's Avatar
Club Car
 
Join Date: Sep 2011
Location: Florida
Posts: 13,006
Default Re: Ignition got wet!

Looks sharp
NoleFan4Ever is offline   Reply With Quote
Unread 08-08-2017, 06:24 PM   #7
Not Yet Wild
 
tanman's Avatar
Club Car
 
Join Date: Nov 2016
Location: NJ
Posts: 11
Default Re: Ignition got wet!

Thanks it's my first build. I had a lot of fun with it. I did it from top to bottom.

Sent from my SM-N920V using Tapatalk
tanman is offline   Reply With Quote
Unread 08-09-2017, 07:19 PM   #8
Gone Wild
 
Down South's Avatar
Club Car
 
Join Date: Aug 2011
Location: Retired now and back home in Louisiana
Posts: 734
Default Re: Ignition got wet!

Let it set in the sunshine for a day. Should cure it.
Down South is offline   Reply With Quote
Unread 08-09-2017, 10:53 PM   #9
MOD of all BS!
 
NoleFan4Ever's Avatar
Club Car
 
Join Date: Sep 2011
Location: Florida
Posts: 13,006
Default Re: Ignition got wet!

Quote:
Originally Posted by Down South View Post
Let it set in the sunshine for a day. Should cure it.
Man you are late DS. We fixed that 2 days ago....
NoleFan4Ever is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Ignition Gas EZGO
Ignition help Gas EZGO
Pre MCI ignition and MCI ignition parts compatibility Gas EZGO
Ignition Gas EZGO
Yamaha G9-Ignition Coil & Ignition Switch-Help Gas Yamaha


All times are GMT -5. The time now is 05:32 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.