lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-09-2018, 10:39 AM   #1
Not Yet Wild
E-Z-GO
 
Join Date: Jun 2013
Location: Ohio
Posts: 41
Default 1987 CC electric speed issue

Have a 1987 club car electric that doesn't want to accelerate properly. Have replaced all 5 solenoids and tested micro switches. really only accelerates a lot at the 4th and 5th solenoids, really jerks at that point. basically cannot get a smooth transition of speed from the 2nd and 3rd solenoids to the 4th and 5th solenoids. Any help would be great.
WGCS is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-09-2018, 10:44 AM   #2
Gone Wild
 
LukeL's Avatar
Club Car
 
Join Date: Jun 2017
Location: Savannah, GA
Posts: 1,040
Default Re: 1987 CC electric speed issue

Itís probably an issue with your V-Glide. Have you checked to make sure the wiper moves smoothly over all the contacts, and the cables are in good shape and tight?


Sent from my iPhone using Tapatalk
LukeL is offline   Reply With Quote
Unread 01-09-2018, 10:47 AM   #3
Not Yet Wild
E-Z-GO
 
Join Date: Jun 2013
Location: Ohio
Posts: 41
Default Re: 1987 CC electric speed issue

this unit doesn't have a v-glide. the solenoids are activated by 5 micro switches inside what i believe is called the "speed switch" assembly
WGCS is offline   Reply With Quote
Unread 01-09-2018, 10:50 AM   #4
Gone Wild
 
LukeL's Avatar
Club Car
 
Join Date: Jun 2017
Location: Savannah, GA
Posts: 1,040
Default Re: 1987 CC electric speed issue

Ok. Sorry about that. I had a 1988 with a V-Glide before I converted it. Iím not as familiar with the microswitch version, even though Iíve messed with them a little. Hopefully some of the experts will come along soon...


Sent from my iPhone using Tapatalk
LukeL is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2008 electric club car speed sensor issue? Electric Club Car
1987 club car choke issue and fuel gauge not working Gas Club Car
1987 EZGO gas backfire issue Gas EZGO
electric club car 1987 - electrical issue Electric Club Car
speed control issue 92 e z go electric Electric EZGO


All times are GMT -5. The time now is 06:44 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.