lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-28-2018, 02:42 PM   #1
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 3,521
Default Bad battery

I have a set on t875's in my DS cart. Playing golf the other day we were gong up a steep hill and my cart got real slow, my rider got off and the cart made it on up. These batteries are 3 years old this month. I got home and checked the voltages and number 5 was only showing 6.1 volts. After charging the next day cart did just fine and after playing at home the same battery was 8.35 volts.

I will be taking it to my Trojan dealer tomorrow for replacement, it let me down one time, I'm not going to trust that it repaired itself. I would bet that under a load going up that same hill it would do it again. I'll be taking it to the place I bought it. These guys are home fokes so I may get a free 2015 battery or a 2018 at a discount price. They are fair people I know that.
mrgolf is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-30-2018, 12:44 AM   #2
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 3,521
Default Re: Bad battery

Well I got another battery. They tested my old one. The hydrometer showed all cell were really good. The they put a load on it. At 50 amps it held the voltage really good. I was thinking I was stupid. Then he raised the amps to 100 amps and the voltage dropped to a little over 6 volts, it held that up over 200 amps.
I guess somehow one cell was dropping out under heavy load.

We never went back and checked it at under 100 amps. Should have but I was convinced the battery was bad and was never going to put it back in a cart.
mrgolf is offline   Reply With Quote
Unread 01-30-2018, 01:06 AM   #3
Gone Insane
 
Mooncarter's Avatar
Club Car
 
Join Date: Oct 2016
Location: Richmond, VA
Posts: 7,095
Default Re: Bad battery

Bad luck I guess.
Mooncarter is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Does a 2014 or newer with battery gauge flash the battery warning light? Electric Club Car
2014 w/factory battery gauge, battery warning light not working Electric Club Car
Couple Questions, Golf cart cuts out, battery replacement time, and battery meter? Electric Club Car
Yamaha YDRE Factory Battery SoC Meter: Brand? Also: Battery Charger Question Electric Yamaha
Trojan Ranger 160 battery terminals overheating and melting battery plastic Electric Club Car


All times are GMT -5. The time now is 06:41 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.