lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-15-2009, 01:47 PM   #1
Not Yet Wild
 
Join Date: Mar 2009
Posts: 1
Default 04 CC takes off normal then slows down.

04 IQ takes off normal, good boost of speed, then drops down to a speed equivalent to that of reverse. Reverse works normal. called dealer and he mentioned maybe speed sensor or mcore. we have tried to reset computer, thinking that may help, but our instructions are worded too vague. it just says disconnect battery 1 & 6 from motor, turn key on, switch in reverse, hold throttle pedal down until buzz stops. well if you disconnect the leads from batt 1 & 6, the buzzer doesnt operate at all. so we disconnect green & white from motor and buzzer operates & hold down pedal for like 30 seconds and buzz never stops. so we disconnect all four wires from motor and same thing.

do you think resetting the computer might help? anybody have more explicit instructions for reset/reboot computer?

we tried disconnecting the speed sensor from the motor and it ran the same. was running beatiful, then all of a sudden this started happening out of the blue.

oh, We have a high speed chip installed from the dealer.

any ideas?

thanks everyone.

Last edited by brobins75; 03-15-2009 at 01:55 PM.. Reason: more info
brobins75 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-16-2009, 01:29 AM   #2
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,238
Default Re: 04 CC takes off normal then slows down.

Hello brobins75 and Welcome to the forum.

Just wanted to let ya know folks "are" seeing your post, just no takers yet.

Someone will hit it soon.
rusty is offline   Reply With Quote
Unread 03-17-2009, 09:25 AM   #3
Just me. .
 
phasetim's Avatar
Club Car
 
Join Date: Sep 2007
Location: Pensacola, FL
Posts: 1,092
Default Re: 04 CC takes off normal then slows down.

speed sensor failure sound like your culprit.. The failure could be in the controller, or the motor sensor.

What happens, is the controller detects a fault and then slows your car down to a "get home" mode... ...

Unplugging the sensor immediately faults. The problem is best handled by a dealer.

Replacing the sensor involves disassembling the motor, and then it may be a controller problem anyways.
phasetim is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2003 ezgo just slows down Electric EZGO
electric cart slows down Electric Club Car
91 CC Takes Off In Reverse Electric Club Car
Yamaha takes offs Golf Carts and Parts


All times are GMT -5. The time now is 05:14 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.