lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 02-17-2018, 05:48 PM   #1
Not Yet Wild
 
Join Date: Jan 2018
Posts: 8
Unhappy 2011 Club Car Precedent going half speed

OK... So far I have brand new batteries, a new 48 V smart Lester charger with an OBC bypass, a new solonoid, a new MCOR and a new speed sensor. The cart does everything it should except kick into high gear. Back up buzzer works and it goes in reverse just fine, but in forward it's only going about half the speed it should. (it's slow)...Any ideas on what I should be looking for or adjusting??
lee general is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 02-17-2018, 06:19 PM   #2
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 3,597
Default Re: 2011 Club Car Precedent going half speed

Lots on times the Internet speed sensors are bad out of the box. Your magnet could be broken. If the solenoid does not open like it should when you let off the go pedal that will put the cart in limp mode 8 mph. Also the controller could be bad.

Just something to get you started.
mrgolf is online now   Reply With Quote
Unread 02-17-2018, 07:38 PM   #3
revolutiongolfcars.com
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 9,707
Default Re: 2011 Club Car Precedent going half speed

The problem is more than likely a broken magnet or a Chinese speed sensor. Chinese speed sensor can be easily identified by the wire colors. Red, Black, and Blue. OEM sensor wire colors are Red, Black, and Green.
TahoeDawgZ71 is offline   Reply With Quote
Unread 02-18-2018, 05:10 AM   #4
Not Yet Wild
 
Join Date: Jan 2018
Posts: 8
Default Re: 2011 Club Car Precedent going half speed

Thanx guys! I'll try a new magnet!
Can the magnet be put in facing the wrong way?
lee general is offline   Reply With Quote
Unread 02-18-2018, 06:38 PM   #5
revolutiongolfcars.com
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 9,707
Default Re: 2011 Club Car Precedent going half speed

Quote:
Originally Posted by lee general View Post
Thanx guys! I'll try a new magnet!
Can the magnet be put in facing the wrong way?
On a GE motor yes, on an AMD motor, it doesn't matter.
TahoeDawgZ71 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2011 CLub Car Precedent Speed Electric Club Car
2011 precedent excel speed upgrades Electric Club Car
2010 Precedent half speed Electric Club Car
2011 club car precedent speed code 4 ??? Electric Club Car
Club Car half speed. Electric Club Car


All times are GMT -5. The time now is 06:10 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.