lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-08-2018, 09:02 AM   #11
Not Yet Wild
 
Join Date: Dec 2015
Location: Rock Hill, SC
Posts: 58
Default Re: Rear wheel makes a rubbing noise

You don't need to disconnect the battery from the rest of the pack, you can check each battery while it's connected, and then test the whole pack to see if everything adds up
geonjay is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-08-2018, 06:10 PM   #12
Gone Wild
 
yawood's Avatar
Club Car
 
Join Date: Jan 2017
Location: Melbourne Australia
Posts: 944
Default Re: Rear wheel makes a rubbing noise

Quote:
Originally Posted by geonjay View Post
It was a little more than 13 hours after the charger shutoff, but the batteries were 12.7, 12.7, 12.8, and 12.7 - which is 50.9, but the meter read 51.1 across the entire pack. The battery performance has been declining for a few months - could the charger have been slowly failing and impacting the batteries? It seems like a failed relay or breaker would have just gone dead, not slowly died.
I assume you've read the sticky about charger troubleshooting Charging System Troubleshooting? If not, you should read it and any others on testing the charger.
yawood is offline   Reply With Quote
Unread 03-09-2018, 11:17 AM   #13
Not Yet Wild
 
Join Date: Dec 2015
Location: Rock Hill, SC
Posts: 58
Default Re: Rear wheel makes a rubbing noise

Thanks for the pointer! Yes, I read the sticky and found the Lester Electronics charger troubleshooting guide. I also called and talked to TahoeDawg and, upon his advice, went ahead and ordered some replacement parts. I'll get them installed this weekend and we'll see how it goes. The batteries are still 4 years old...so they won't be perfect, but I'm wondering if their sudden drop in performance was related to a failing charger. Although, I would have guessed that the charger would have just failed, and not just declined in performance. Thanks for all of your help!
geonjay is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Rear Axle Rubbing Noise 91 Marathon Electric EZGO
Rear Wheel grinding noise? Electric EZGO
G14 rear wheel makes a clicking noise Electric Yamaha
Rear wheel not turning, noise in rear end Electric Club Car


All times are GMT -5. The time now is 07:40 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.