lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-27-2018, 06:35 AM   #1
Not Yet Wild
 
Join Date: Apr 2017
Posts: 15
Default I give up!!

Ok guys have a 1992 Club Car DS 36 volts. Long story short mother was driving it she stopped went to turn it back on heard a pop by the key. Took it apart didnít look burnt or anything even put the wires together and still wonít run. Noticed that the silonoid was melted so replace. While I had body off cleaned all the contacts in the process some of was very brittle I ended up replace v glide,forward reverse switch and fuse block anybody can help me I have some pictures. I have even replace the micro switch in v glide and forward reverse switch!?!!?!


Sent from my iPhone using Tapatalk
jakecliff22 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-27-2018, 08:31 AM   #2
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 68,718
Default Re: I give up!!

Does the solenoid click when you try to go?
scottyb is offline   Reply With Quote
Unread 03-27-2018, 02:13 PM   #3
Not Yet Wild
 
Join Date: Apr 2017
Posts: 15
Default Re: I give up!!

Quote:
Originally Posted by scottyb View Post
Does the solenoid click when you try to go?


The only thing I can hear is the micro switch clicking from the v glide


Sent from my iPhone using Tapatalk
jakecliff22 is offline   Reply With Quote
Unread 03-27-2018, 03:28 PM   #4
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 68,718
Default Re: I give up!!

You should be getting 36v between the 2 small wires on the solenoid when the key on, F&R in gear, pedal down. This should make the solenoid click and the cart go.
scottyb is offline   Reply With Quote
Unread 03-27-2018, 05:39 PM   #5
Not Yet Wild
 
Join Date: Apr 2017
Posts: 15
Default Re: I give up!!

Quote:
Originally Posted by scottyb View Post
You should be getting 36v between the 2 small wires on the solenoid when the key on, F&R in gear, pedal down. This should make the solenoid click and the cart go.


Iím getting 37 volts but no clicking


Sent from my iPhone using Tapatalk
jakecliff22 is offline   Reply With Quote
Unread 03-27-2018, 06:57 PM   #6
revolutiongolfcars.com
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 9,793
Default Re: I give up!!

Quote:
Originally Posted by jakecliff22 View Post
Iím getting 37 volts but no clicking


Sent from my iPhone using Tapatalk
Bad solenoid.
TahoeDawgZ71 is offline   Reply With Quote
Unread 03-27-2018, 07:03 PM   #7
Not Yet Wild
 
Join Date: Apr 2017
Posts: 15
Default Re: I give up!!

Quote:
Originally Posted by TahoeDawgZ71 View Post
Bad solenoid.


But I replaced solenoid could that be bad also?


Sent from my iPhone using Tapatalk
jakecliff22 is offline   Reply With Quote
Unread 03-27-2018, 07:04 PM   #8
revolutiongolfcars.com
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 9,793
Default Re: I give up!!

If you're getting voltage to the two small terminals on the solenoid and it doesn't click, it's bad.
TahoeDawgZ71 is offline   Reply With Quote
Unread 03-27-2018, 08:32 PM   #9
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 68,718
Default Re: I give up!!

Or the wrong solenoid?
scottyb is offline   Reply With Quote
Unread 03-27-2018, 08:38 PM   #10
revolutiongolfcars.com
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 9,793
Default Re: I give up!!

Quote:
Originally Posted by scottyb View Post
Or the wrong solenoid?
Yep, or the wrong solenoid.
TahoeDawgZ71 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
I had to give it a try. Electric Club Car
G1 I think i give up!! Gas Yamaha
i give up Electric Yamaha


All times are GMT -5. The time now is 07:37 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.