lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-12-2018, 06:45 PM   #1
Not Yet Wild
 
Join Date: Apr 2018
Posts: 20
Default 2003 Club Car w/ Solid State Conversion Kit Won't Go

I have a 2003 Club Car, formerly 36V V-glide. I bought the solid state conversion kit from Scottyb to (going up to 48V w/ 6x8V batteries) and have everything wired up. Unfortunately, the cart won't go. My observations from troubleshooting so far:

1) When I turn the key switch and push the pedal, nothing happens. Not even a solenoid click.

2) I have checked the batteries. Each read over 8V and 50V over the whole bank.

3) I have confirmed continuity of the key switch (connected to main pos and pedal with new wires). I have also confirmed continuity across the small terminals on the solenoid.

4) Based on other info I found here, I tried to run jumpers from the main pos and neg of the battery bank to the small terminals on the solenoid. I connected the first jumper from main neg to the solenoid, attached the second jumper to the solenoid, and when I touched the jumper clip to the main pos, it blew the second jumper completely off the solenoid.

I'm a bit stumped. Any ideas?
Sigma is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-12-2018, 06:55 PM   #2
Gone Wild
Club Car
 
Join Date: Apr 2017
Posts: 351
Default Re: 2003 Club Car w/ Solid State Conversion Kit Won't Go

You had the polarity reversed. There is a diode on the solenoid. Which is probably shorted now.
WalterM6 is online now   Reply With Quote
Unread 05-12-2018, 08:00 PM   #3
Garnet & Gold Certified
 
NoleFan4Ever's Avatar
Club Car
 
Join Date: Sep 2011
Location: Florida
Posts: 3,915
Default Re: 2003 Club Car w/ Solid State Conversion Kit Won't Go

When you ran the two 48 volt jumpers, you did run them with the 48v Pos to one of the "Small" posts and the 48v Neg to the other "Small" post of the solenoid. So then the two large post did not have any jumpers at all..... Is this correct? (cause if you ran them to the two large posts it would do what you described when you applied the Negative side as that would have positive voltage already on it from the main pack cable ) And did you remove the existing wires from the small posts prior to running the jumpers, as you do not want to apply 48v Pos where the 48v Neg was already coming in....
NoleFan4Ever is offline   Reply With Quote
Unread 05-12-2018, 08:25 PM   #4
Not Yet Wild
 
Join Date: Apr 2018
Posts: 20
Default Re: 2003 Club Car w/ Solid State Conversion Kit Won't Go

Quote:
When you ran the two 48 volt jumpers, you did run them with the 48v Pos to one of the "Small" posts and the 48v Neg to the other "Small" post of the solenoid. So then the two large post did not have any jumpers at all..... Is this correct?
Yes, this is correct. I didn't jump the large posts...they remained connected with the 2 gauge wires as-is (Pos to Main Pos/Fuse, Neg to B+ on the controller).

Quote:
And did you remove the existing wires from the small posts prior to running the jumpers, as you do not want to apply 48v Pos where the 48v Neg was already coming in....
Yes, I removed the existing wires to the small posts before connecting the jumpers.

I know arching is not uncommon when it comes to battery cables, but this seemed like more than arching. I was using a clip to connect the jumper to the main pos and when it blew off, it melted a pretty good chunk off of the clip onto the battery post. After that happened, I figured I'd come ask for help. But maybe it was no big deal...
Sigma is offline   Reply With Quote
Unread 05-13-2018, 09:04 AM   #5
Carts Unlimited .net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 65,690
Default Re: 2003 Club Car w/ Solid State Conversion Kit Won't Go

The diode was installed backwards. It is destroyed now, order a new one.
scottyb is offline   Reply With Quote
Unread 05-13-2018, 10:08 AM   #6
Not Yet Wild
 
Join Date: Apr 2018
Posts: 20
Default Re: 2003 Club Car w/ Solid State Conversion Kit Won't Go

Quote:
The diode was installed backwards. It is destroyed now, order a new one.
Thanks Scotty. What makes you think the diode was installed backwards?

ETA:

Here's a pic of how the diode is connected.



Then from the pos spade terminal, I have connected 3 wires: the blue wire from the pedal, a wire to the KS1 (red) terminal on the controller, and the positive terminal on the rocker switch.

And from the neg spade terminal, I have connected 1 wire: a wire to J1 (blk) on the controller.

Sigma is offline   Reply With Quote
Unread 05-13-2018, 02:37 PM   #7
Carts Unlimited .net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 65,690
Default Re: 2003 Club Car w/ Solid State Conversion Kit Won't Go

The picture confirms my suspicion. The banded end is +. See the instruction for diode installation instruction.
scottyb is offline   Reply With Quote
Unread 05-13-2018, 03:03 PM   #8
Not Yet Wild
 
Join Date: Apr 2018
Posts: 20
Default Re: 2003 Club Car w/ Solid State Conversion Kit Won't Go

Quote:
Originally Posted by scottyb View Post
The picture confirms my suspicion. The banded end is +. See the instruction for diode installation instruction.
I see now. Thanks for your help
Sigma is offline   Reply With Quote
Unread 05-15-2018, 07:35 PM   #9
Not Yet Wild
 
Join Date: Apr 2018
Posts: 20
Default Re: 2003 Club Car w/ Solid State Conversion Kit Won't Go

Replaced the diode and installed with banded end to pos. Still nothing. No solenoid click. What should I check next?
Sigma is offline   Reply With Quote
Unread 05-15-2018, 07:38 PM   #10
Garnet & Gold Certified
 
NoleFan4Ever's Avatar
Club Car
 
Join Date: Sep 2011
Location: Florida
Posts: 3,915
Default Re: 2003 Club Car w/ Solid State Conversion Kit Won't Go

If there is no click, then you are missing the 48v + & - needed for the energizing coil to close in OR if you have them, the solenoid is stuck or has failed.
NoleFan4Ever is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
86 club car ds solid state conversion Electric Club Car
1974 Club Car Caroche solid state conversion help Electric Club Car
1989 club car conversion to solid state controller Electric Club Car
Club Car Solid state conversion kit Golf Carts and Parts


All times are GMT -5. The time now is 07:16 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.