lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-28-2018, 05:09 PM   #11
Not Yet Wild
 
Join Date: Aug 2008
Posts: 19
Default Re: Speed Sensor issues

Interesting... i went back out and took it for a spin - working great now... time shall tell I guess.

I tell you what... its quite fast when it works right!!!
mangus580 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
MCOR? Speed Sensor? Controller? Cart Runs at half speed. Advice, please. Electric Club Car
WTB Ezgo Speed Sensor Cable (Without Sensor) Golf Carts and Parts
2010 Tomberlin Emerge Speed Sensor issues Tomberlin
Speed sensor issues with plum quick motors? Electric Club Car
08 precedent electric speed sensor problem. Cart starts at proper speed then slows . Electric Club Car


All times are GMT -5. The time now is 06:48 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.