lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-11-2018, 03:36 PM   #1
Not Yet Wild
Yamaha
 
Join Date: Oct 2016
Location: Gleniffer Lake Resort ALBERTA Canada
Posts: 22
Default Go no go🤔

I am working on a 2007 Club Car Precedent with 4 new fully charged batteries.
It will go about 50 feet in either forward or reverse then just quits and each successive attempt you get less distance,this is why the owner went NDE bought new batteries. I was able to borrow a scan tool from the golf course to check the problem . It never shows a current fault but in history it has Main Drop Out,
Main Coil Fault, Low Voltage.
With monitor connected the throttle (MCOR) goes all the way to 100 percent and shows smooth consistent rise and decent both ways.
The voltage reading is total pack voltage (52v)but when you depress the pedal in forward or backward the voltage drops to 2-3volts as it quits moving.
It is a long drive to the dealer for parts so I only want to go once and the owner has already bought batteries he didn't need
Any help would be appreciated
Papas 73Dart is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-11-2018, 03:43 PM   #2
Garnet & Gold Certified
 
NoleFan4Ever's Avatar
Club Car
 
Join Date: Sep 2011
Location: Florida
Posts: 7,270
Default Re: Go no go🤔

That sure sounds like a failure in the solenoid (itself or the energizing coil)

And you are sure the microswitch in the MCOR is not dropping out causing you to lose the coil activation....?
NoleFan4Ever is offline   Reply With Quote
Unread 07-11-2018, 07:42 PM   #3
Not Yet Wild
Yamaha
 
Join Date: Oct 2016
Location: Gleniffer Lake Resort ALBERTA Canada
Posts: 22
Talking Re: Go no go🤔

I did some more tests today right out of the Club Car manual and the coil seem to pass all the ohm test but still kept cutting out. It always set a history fault code :Main drop out and sometimes low battery voltage and main coil fault.
I decided to remove the coil and there is strong burnt electrical smell.
Borrowed a coil from another cart and the problem went away
Thanks for the help
Papas 73Dart is offline   Reply With Quote
Unread 07-11-2018, 08:18 PM   #4
Garnet & Gold Certified
 
NoleFan4Ever's Avatar
Club Car
 
Join Date: Sep 2011
Location: Florida
Posts: 7,270
Default Re: Go no go🤔

Glad to hear it....
NoleFan4Ever is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes



All times are GMT -5. The time now is 09:08 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.