lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-12-2018, 02:30 PM   #1
JDC
Gone Wild
 
Join Date: Jun 2009
Location: Ontario Canada
Posts: 164
Default cutting out

2004 precedent 48 volt take off with it and above or around half throttle it quits and if you let the throttle back off it starts moving again. if you push the throttle down quick it wont move at all. it has a new controller and throttle pedal and speed sensor.
JDC is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-12-2018, 11:19 PM   #2
Garnet & Gold Certified
 
NoleFan4Ever's Avatar
Club Car
 
Join Date: Sep 2011
Location: Florida
Posts: 6,328
Default Re: cutting out

The Potentiometer in your MCOR is failing and will need to be replaced. https://www.revolutiongolfcars.com/mcors

Call David if you are not sure which pedal design you have.
NoleFan4Ever is offline   Reply With Quote
Unread 08-13-2018, 04:32 PM   #3
JDC
Gone Wild
 
Join Date: Jun 2009
Location: Ontario Canada
Posts: 164
Default Re: cutting out

its new . so maybe a bad wire between pedal and controller
JDC is offline   Reply With Quote
Unread 08-13-2018, 07:47 PM   #4
revolutiongolfcars.com
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,856
Default Re: cutting out

Sounds like low voltage to me. What's the total battery pack voltage when measure with a multimeter?
TahoeDawgZ71 is offline   Reply With Quote
Unread 08-14-2018, 05:23 PM   #5
JDC
Gone Wild
 
Join Date: Jun 2009
Location: Ontario Canada
Posts: 164
Default Re: cutting out

its at 48. i hooked a multi meter up and watch it while i depressed the acc. there was no major drop. maybe ill try hooking to the motor and see if there is a drop.
JDC is offline   Reply With Quote
Unread 08-27-2018, 08:51 PM   #6
JDC
Gone Wild
 
Join Date: Jun 2009
Location: Ontario Canada
Posts: 164
Default Re: cutting out

I replaced the main harness today and its the same half throttle and it quits.
JDC is offline   Reply With Quote
Unread 08-27-2018, 08:59 PM   #7
Not Yet Wild
 
Cynikal.Mindset's Avatar
 
Join Date: Jul 2018
Posts: 38
Default Re: cutting out

48v sounds low for a charged pack to me.
Cynikal.Mindset is offline   Reply With Quote
Unread 08-28-2018, 07:04 PM   #8
JDC
Gone Wild
 
Join Date: Jun 2009
Location: Ontario Canada
Posts: 164
Default Re: cutting out

I charged the cart lastnight till tonight charger had shut off and pack was at 52 so i replaced the seliniod and tried it and it does the same thing. I tried pushing the cart and got no beeping for roll away fwd or rev. When the cart came to me they had replaced the controller and the MCOR and the speed sensor. ive replaced the harness because of coroded pins and a burnt pin. and the seliniod now. Whats the magnet they talk about on some posts on here and where is it and is it replacable?
JDC is offline   Reply With Quote
Unread 08-28-2018, 08:00 PM   #9
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 3,270
Default Re: cutting out

Know you said you replaced them, but you have problem of a bad speed sensor and a bad MCOR.
mrgolf is online now   Reply With Quote
Unread 08-28-2018, 08:07 PM   #10
revolutiongolfcars.com
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,856
Default Re: cutting out

Quote:
Originally Posted by JDC View Post
I charged the cart lastnight till tonight charger had shut off and pack was at 52 so i replaced the seliniod and tried it and it does the same thing. I tried pushing the cart and got no beeping for roll away fwd or rev. When the cart came to me they had replaced the controller and the MCOR and the speed sensor. ive replaced the harness because of coroded pins and a burnt pin. and the seliniod now. Whats the magnet they talk about on some posts on here and where is it and is it replacable?
Make sure they replaced the speed sensor with an OEM unit. Those Chinese ones are garbage. You can identify it easily. Factory sensor has red, black, and green wires. Chinese crap sensor has Red, Black, and Blue. The magnet we speak about on here is beneath the speed sensor. If it's broken it can give you the same symptoms as a bad speed sensor. Broken magnets are rare.
TahoeDawgZ71 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
G29 cutting out Gas Yamaha
g2 cutting out Gas Yamaha
Par car cutting out Gas Columbia ParCar
G16 cutting off Gas Yamaha
97 G16 Cutting out at WOT Gas Yamaha


All times are GMT -5. The time now is 07:24 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.