lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-16-2018, 02:18 PM   #1
Not Yet Wild
 
Join Date: Aug 2018
Posts: 2
Default Little to no travel

So I installed a 6" lift on my DS and now have no travel. I have troubleshot this thing as far as the controller. Checked Accelerator pot, motor for shorts, all batteries (some are reading low), just got off charge. The cart was fast and ran great prior to the lift. I just replaced the speed sensor due to the old one having a busted magnet. The cart will move a few feet but is very jerky and slow. I feel like I have a bad controller but don't want to waste the money if that's not it.
Rsouth56 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-16-2018, 02:38 PM   #2
Gone Wild
 
WalterM6's Avatar
Club Car
 
Join Date: Apr 2017
Posts: 1,261
Default Re: Little to no travel

A common problem when installing lifts is that the F1 F2 leads get pulled loose from the controller. Is the solenoid pulling in? Did you make any sparks installing the lift?
WalterM6 is offline   Reply With Quote
Unread 08-16-2018, 03:28 PM   #3
Not Yet Wild
 
Join Date: Aug 2018
Posts: 2
Default Re: Little to no travel

SO I just discovered that the motor seems to be fighting itself and A1 lead will begin smoking if I try to travel for about 10 seconds. Every now and then it will take off, but again it is traveling in the fwd direction no mater what the switch is doing. I have checked the switch and the splices in the harness and all seems good
Rsouth56 is offline   Reply With Quote
Unread 08-16-2018, 03:43 PM   #4
revolutiongolfcars.com
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 9,852
Default Re: Little to no travel

If the car is traveling the same direction, but acting as if it's struggling, you've damaged your controller. This typically happens when you're working in the general area of the motor and do not disconnect the batteries AND put the system in TOW. All it takes is a small arc between two of the terminals on the motor and the controller will fail.
TahoeDawgZ71 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Long Travel or SOL? Electric Club Car
How Far Can I Travel Electric Club Car
Look at this Long Travel kit Lifted Golf Carts
97 cc ds will not travel Electric Club Car
Pedal travel and PB-6 lever travel coming up short Electric Club Car


All times are GMT -5. The time now is 07:47 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.