lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-30-2009, 09:32 PM   #1
Gone Wild
 
Join Date: Oct 2007
Location: Sebring,Florida
Posts: 156
Default IQ won't go

I have an 05 IQ that ran fine and now here is the issue.New batterys.I turn on the key solenoid clicks,step on go pedal and solenoid clicks again and car sometimes moves an inch sometimes no move.I then must turn key switch off and then back on again to activate solenoid.I have replaced key switch,solenoid and swapped out the controller.I have a IQDM tool and it shows no faults.Any help would be appreciated.
Tom
ltmoeller is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-31-2009, 08:43 AM   #2
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: IQ won't go

More info needed ,
Is it a 36 or 48 Volt system
When did this start happening ?
Whats the story ?
GLEEMO is offline   Reply With Quote
Unread 03-31-2009, 02:05 PM   #3
Just me. .
 
phasetim's Avatar
Club Car
 
Join Date: Sep 2007
Location: Pensacola, FL
Posts: 1,092
Default Re: IQ won't go

go into "test" mode on that iqdm and verify the switches are working correctly...
phasetim is offline   Reply With Quote
Unread 03-31-2009, 05:03 PM   #4
Gone Wild
 
Join Date: Oct 2007
Location: Sebring,Florida
Posts: 156
Default Re: IQ won't go

gmorrison,reread my thread.Everything you ask is there.
Phasetim,I did the test this morning and found it to be a bad mcor.I could never get a throttle1 fault but today doing some tests iqdm showed pedal on when I first deprested it to activate solenoid,then a tad more throttle test showed pedal off.Replaced mcor and all is good.
Thanks,Tom
ltmoeller is offline   Reply With Quote
Unread 03-31-2009, 06:08 PM   #5
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: IQ won't go

Hey glad to know , you found the problem !
And from your last mail I am assuming the IQ comes only in 48 Volt (log to memory)
And also assuming from your last email that it ran before U installed New Batteries, sooo, U blew the mcor when installing the Batteries ?
GLEEMO is offline   Reply With Quote
Unread 03-31-2009, 09:22 PM   #6
Gone Wild
 
Join Date: Oct 2007
Location: Sebring,Florida
Posts: 156
Default Re: IQ won't go

Gmorrison:Batterys were installed a month ago and cart has been running fine before the issue popped up.No I did not blow the mcor when installing batterys.To help you understand some things about the IQ system You always put the tow/run in tow before disconnecting batt.cable.Failure to do so can blow the controller.I never heard of blowing a mcor.
ltmoeller is offline   Reply With Quote
Unread 04-01-2009, 09:25 AM   #7
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Thumbs down Re: IQ won't go

Well there U go, a little History , Nice !
It's all just termonalogy, Blown, grap out, fried ...etc. Pick one .
GLEEMO is offline   Reply With Quote
Unread 04-01-2009, 10:41 AM   #8
Just me. .
 
phasetim's Avatar
Club Car
 
Join Date: Sep 2007
Location: Pensacola, FL
Posts: 1,092
Default Re: IQ won't go

The fault mode only lets you know understood faults at the controller. If the micro switch in the mcor fails then it simply detects a switch being off. A throttle fault detects a strange reading with throttle not a failed one.
phasetim is offline   Reply With Quote
Unread 04-01-2009, 05:40 PM   #9
Gone Wild
 
Join Date: Oct 2007
Location: Sebring,Florida
Posts: 156
Default Re: IQ won't go

Phasetim,Yes I was reading the micro opening and closing,but not fault reading.So I figured the mcor was ok.So Just because I had a open/close reading the circuit board inside the mcor was gone.I see what your saying.
Thanks,Tom
ltmoeller is offline   Reply With Quote
Unread 04-01-2009, 06:04 PM   #10
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: IQ won't go

Where did the circuit board go ? Stolen
GLEEMO is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes



All times are GMT -5. The time now is 11:53 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.