lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-12-2018, 06:52 PM   #1
Not Yet Wild
Club Car
 
Join Date: Dec 2018
Location: Ashtabula ohio
Posts: 3
Default Batteries issue/ 2006 club car precedent

Hello im new to the forum and buggies. i need some help i have a 2006 CC precedent , i check the 4 batteries w/ multimeter there reading 12.6 volts, however i plug the powerdrive charger it goes to 6 amp then down to 4 i checked all the wires and fuses and no problems there any suggestions ? Thanks
Dragons70 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 12-12-2018, 08:23 PM   #2
Master of All Things
 
Sir Nuke's Avatar
E-Z-GO
 
Join Date: May 2013
Location: West Columbia, Texas
Posts: 11,534
Default Re: Batteries issue/ 2006 club car precedent

Welcome to our happy little corner of the net, and to BGW. There is a BIG fridge on the back porch with anything you can think of in it...help yourself...of course only take what you can LEGALLY have. Make yourself at home on one of the big fluffy couches, kick your shoes off, put your feet up on one of the tables, yes we are allowed to do that, mom's, wives’, husbands, girlfriend’s and boyfriends here don't care....and take it easy.



oh...btw....every once in a while a food fight breaks out...so you may not want to wear nice clothes here.

Welcome!!
Sir Nuke is offline   Reply With Quote
Unread 12-12-2018, 09:35 PM   #3
MOD of all BS!
 
NoleFan4Ever's Avatar
Club Car
 
Join Date: Sep 2011
Location: Florida
Posts: 12,209
Default Re: Batteries issue/ 2006 club car precedent

Quote:
Originally Posted by Dragons70 View Post
Hello im new to the forum and buggies. i need some help i have a 2006 CC precedent , i check the 4 batteries w/ multimeter there reading 12.6 volts, however i plug the powerdrive charger it goes to 6 amp then down to 4 i checked all the wires and fuses and no problems there any suggestions ? Thanks
You are at 50.4 and 50.9 is fully charged. What is it doing that concerns you? If the OBC is reading the energy units as almost replenished it is not going to max out.

If you want to reset the OBC, just flip your Run/Tow switch to Tow and then remove the main pack Negative cable for ~20 minutes and then reconnect it, flip the switch back to Run and plug the charge receptacle back into the cart.
NoleFan4Ever is offline   Reply With Quote
Unread 12-13-2018, 09:33 AM   #4
Not Yet Wild
Club Car
 
Join Date: Dec 2018
Location: Ashtabula ohio
Posts: 3
Default Re: Batteries issue/ 2006 club car precedent

Thank you my concern is shouldn't the charger should read 12 on a fully charged batteries? the charger was doing that before, now winter is here its only reading 6 on charged batteries ?
Dragons70 is offline   Reply With Quote
Unread 12-13-2018, 10:41 AM   #5
Not Yet Wild
Club Car
 
Join Date: Aug 2016
Location: Charlotte, NC
Posts: 51
Default Re: Batteries issue/ 2006 club car precedent

I know this one. Let me, let me answer. Your charger meter is showing the "AMPS" going into your batteries and not volts. When your Batts are low the charger will initially provide high amperage. As the batteries charge, the amperage meter will drop. Fully charged batteries, with little or no use, when plugged in again will quickly show low amperage going from the charger into the batteries and will automatically shut off much sooner than a normal charging session.


Sent from my iPhone using Tapatalk
SCCLT is offline   Reply With Quote
Unread 12-13-2018, 12:25 PM   #6
MOD of all BS!
 
NoleFan4Ever's Avatar
Club Car
 
Join Date: Sep 2011
Location: Florida
Posts: 12,209
Default Re: Batteries issue/ 2006 club car precedent

Quote:
Originally Posted by Dragons70 View Post
Thank you my concern is shouldn't the charger should read 12 on a fully charged batteries? the charger was doing that before, now winter is here its only reading 6 on charged batteries ?
Do not be surprised if you see a slower charge in colder weather and you will see a lower self discharge.

Again, resetting the OBC is the best thing to do to give you back the confidence you seek.
NoleFan4Ever is offline   Reply With Quote
Unread 12-13-2018, 06:04 PM   #7
Not Yet Wild
Club Car
 
Join Date: Dec 2018
Location: Ashtabula ohio
Posts: 3
Default Re: Batteries issue/ 2006 club car precedent

ok thank you i will reset the obc thanks again
Dragons70 is offline   Reply With Quote
Unread 12-14-2018, 09:46 AM   #8
Gone Wild
 
mgray70's Avatar
E-Z-GO
 
Join Date: Apr 2013
Location: Deep Run, NC
Posts: 1,614
Default Re: Batteries issue/ 2006 club car precedent

Sounds like it's performing perfectly to me. Like SCCLT said, they meter is reading "amps" not volts. It's going to slowly drop to 0 and cut off when the batteries are fully charged.

Sent from my SM-G930R4 using Tapatalk
mgray70 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2006 Precedent Voltage Issue Electric Club Car
2006 Precedent discharged batteries Electric Club Car
2006 Precedent - Barely Moves, Batteries Charged Electric Club Car
What Batteries to buy for 2006 Precedent Electric Club Car
Running Time 48V Batteries Precedent 2006, Purchase Side Curtains Electric Club Car


All times are GMT -5. The time now is 12:52 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.