lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-05-2019, 03:56 PM   #1
Not Yet Wild
 
stevewise033's Avatar
 
Join Date: Aug 2018
Posts: 40
Default Battery Charging Issue

Hi everyone. Need some advise / suggestions on battery charger. 2002 Club Car DS 48V. When I bought the cart about 4 months ago, the previous owner had installed an on board charger, and disconnected the plug-in factory charging port at the seat. I don't really have an issue with the current charger set up as it really is convenient for charging the cart wherever I may be with it. What I'm noticing is that I don't think it's "deep charging" my pack. I think I'm only getting what I call a "surface charge" when I plug the cart in after use. The batteries never get warm, much less hot enough to make the water in them bubble. The dash mounted volt meter can show 70% when I plug the charger in, and in 15 minutes it reads 100%. The charger has 6 stages (lights) as it charges, but it goes straight to 6 after just a few minutes. The charger is a Delta Q, QuiQ, Model 912-4800, 48V charger. The cart has Powertron 8000 8V batteries that are 2016 models. All in all the cart runs well and pulls hills pretty well, but it doesn't take a great deal of time for the battery meter to get low. Maybe 4 to 5 miles. But I'm guessing I'm not recharging the batteries like I should be and I'm shortening their life, and probably not getting all of the performance out of the pack that they are capable of. Do i need a different charger or could the batteries just have seen better days ? They seem pretty decent. Thoughts, suggestions, ideas please ??

Sent from my SM-N910V using Tapatalk
stevewise033 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-05-2019, 06:19 PM   #2
dliw enoG
 
Fairtax4me's Avatar
Club Car
 
Join Date: Dec 2015
Location: Charlottesburg Va
Posts: 1,801
Default Re: Battery Charging Issue

It could be that the Quiq charger isn’t configured properly for those batteries. Every battery manufacturer has different charging profiles for their batteries, and if the charger is using the wrong one the batteries won’t charge properly.

Couple things to check first.
Water level in the batteries. Are the plates covered? They should have at least 1/4” of water above them.
Charger wire connections on the batteries. Clean and tight, no corrosion.

Next charge the batteries and let them sit about 12 hours. verify the pack voltage with an Actual Voltmeter. Those little bar gauges are just about worthless IMO. Check voltage of the entire pack and check voltage of each battery individually.
Now drive it about 20 minutes and check voltages again. Compare those to a SOC chart.
Fairtax4me is online now   Reply With Quote
Unread 01-05-2019, 06:29 PM   #3
Not Yet Wild
 
stevewise033's Avatar
 
Join Date: Aug 2018
Posts: 40
Default Re: Battery Charging Issue

Water is good in all batteries. Plates covered. I monitor that regularly. Recently had 2G cables installed. Everything is good and tight. I haven't checked the batteries with a volt meter yet. I'll try to do that tomorrow. The pack is plugged in now for overnight. How do I find out about the battery profile vs the charger ? Thanks for the feedback sir.

Sent from my SM-N910V using Tapatalk
stevewise033 is offline   Reply With Quote
Unread 01-05-2019, 06:52 PM   #4
dliw enoG
 
Fairtax4me's Avatar
Club Car
 
Join Date: Dec 2015
Location: Charlottesburg Va
Posts: 1,801
Default Re: Battery Charging Issue

I did have to look that up because Iím not familiar with the Quiq series chargers. The profile can be changed, but you need to find a delta-q service dealer that has a special interface to connect to the charger.
There can be multiple charge profiles loaded on the charger, but without the interface thereís no way to tell exactly which ones are on it. Kinda makes it pointless to try to update it.

Maybe try asking here in the EZ-go section. I think they used the Quiq chargers.

Beyond that, Try contacting Delta-Q and they may be able to help you find a service dealer or maybe you can buy the interface tool?
Fairtax4me is online now   Reply With Quote
Unread 01-05-2019, 06:59 PM   #5
Gone Wild
E-Z-GO
 
Join Date: Sep 2018
Location: Md.
Posts: 242
Default Re: Battery Charging Issue

Check the delta Quik charger home site. It tells you how to check what profile your charger has. They can also tell you if charger may or may not be changed to another profile for different brands as some models only work with factory spec batteries. HTH.
Cobra,1 is offline   Reply With Quote
Unread 01-05-2019, 07:00 PM   #6
Not Yet Wild
 
stevewise033's Avatar
 
Join Date: Aug 2018
Posts: 40
Default Re: Battery Charging Issue

Good info. Thanks Fairtax4me

Sent from my SM-N910V using Tapatalk
stevewise033 is offline   Reply With Quote
Unread 01-05-2019, 07:01 PM   #7
Not Yet Wild
 
stevewise033's Avatar
 
Join Date: Aug 2018
Posts: 40
Default Re: Battery Charging Issue

Will do Cobra1. Thanks for the response

Sent from my SM-N910V using Tapatalk
stevewise033 is offline   Reply With Quote
Unread 01-05-2019, 07:06 PM   #8
dliw enoG
 
Fairtax4me's Avatar
Club Car
 
Join Date: Dec 2015
Location: Charlottesburg Va
Posts: 1,801
Default Re: Battery Charging Issue

Oh yeah forgot to add this. User manual for the Quiq 1000 series. Available with a bunch of other info in the support section at Delta-Q.com
https://support.delta-q.com/hc/en-us...ser_Manual.pdf
Fairtax4me is online now   Reply With Quote
Unread 01-05-2019, 07:08 PM   #9
Not Yet Wild
 
stevewise033's Avatar
 
Join Date: Aug 2018
Posts: 40
Default Re: Battery Charging Issue

Thanks Fairtax4Me. I appreciate it

Sent from my SM-N910V using Tapatalk
stevewise033 is offline   Reply With Quote
Unread 01-10-2019, 08:36 PM   #10
Not Yet Wild
 
stevewise033's Avatar
 
Join Date: Aug 2018
Posts: 40
Default Re: Battery Charging Issue

Fairtax, I downloaded your link for the charger profiles and followed the new algorithm procedure step by step. I think I have discovered my problem. Apparently the default charge profile has either been erased, or the charger is basically not reprogrammable. It's works enough to put a surface charge on my pack, but it's certainly not deep charging them. I guess my question now is, since the OBC was removed by the previous owner, what are my options now for a new charger to save my batteries before I ruin them, if I haven't already ?? Thanks for any advice

Sent from my SM-N910V using Tapatalk
stevewise033 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Battery Charging Issue Electric Club Car
Battery Charging Issue? Electric Club Car
Battery charging issue Electric EZGO
Charging Issue/ Battery Issue? Electric EZGO
Another battery charging issue Electric Club Car


All times are GMT -5. The time now is 10:51 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.