lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-29-2019, 06:30 PM   #11
Not Yet Wild
Club Car
 
Join Date: Aug 2017
Posts: 12
Default Re: club car charger doesn't activate

This ones on me. Pulled this from memory at work. I have a 2006 48V DS Golf Electric (Curtis IQ). The 97 was my previous model. It makes sense why I didn't recognize the parts you suggested. I still have the same issue with the slowness. Sorry about the screw up.
CoolDaddy is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-29-2019, 08:53 PM   #12
dliw enoG
 
Fairtax4me's Avatar
Club Car
 
Join Date: Dec 2015
Location: Charlottesburg Va
Posts: 2,687
Default Re: club car charger doesn't activate

That makes a big difference!
Slow on a 2006 will usually be a loose throttle linkage that isn't turning the MCOR far enough. A couple of zip ties or a piece of rubber hose on the linkage bar where it meets the pedal will hep with that.
It can also have wear in the pedal pivot bushings which prevent it from turning the linkage full travel. New bushings are inexpensive and relatively easy to install.

Worst case you need a new MCOR.
Fairtax4me is offline   Reply With Quote
Unread 04-02-2019, 09:27 AM   #13
Not Yet Wild
Club Car
 
Join Date: Aug 2017
Posts: 12
Default Re: club car charger doesn't activate

I'll check this out and report back. I do have access to a MCOR for testing if needed.
CoolDaddy is offline   Reply With Quote
Unread 04-10-2019, 03:42 PM   #14
Not Yet Wild
Club Car
 
Join Date: Aug 2017
Posts: 12
Default Re: club car charger doesn't activate

I checked pedal and the MCOR shaft. When pedal was pressed it didn't turn the MCOR shaft until it was about half way. I had some tubing that was the perfect size that I put on the MCOR shaft prongs. That made quite of bit of difference. It still has a little lag but I am going to check the resistance at the MCOR and see it I am seeing the full range. I didn't notice any play with the bushing. It's faster now.
Once again dead on with the information. Thanks.
CoolDaddy is offline   Reply With Quote
Reply

Tags
charger problems, charger relay click
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Gov failure to activate Gas Club Car
2009 RXV will not activate charger Electric EZGO
2006 Carryall Will not take charge or activate charger Electric Club Car
2004 ezgo will not activate charger Electric EZGO
DCS solenoid will not activate Electric EZGO


All times are GMT -5. The time now is 04:15 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.