lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-28-2019, 04:37 PM   #1
Getting Wild
 
bwc_oh33's Avatar
Club Car
 
Join Date: Jun 2018
Posts: 75
Default Alltrax 500 install- 400 amp fuse

Does the 400 amp fuse go to the battery main or negative??? Sheet diagram says positive, Alltrax website says negative... I assume the positive is the correct orientation. Is this correct? Thanks!!!


Sent from my iPhone using Tapatalk
bwc_oh33 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-28-2019, 05:08 PM   #2
Gone Wild
 
Htownblue's Avatar
Club Car
 
Join Date: May 2015
Location: Houston
Posts: 889
Default Re: Alltrax 500 install- 400 amp fuse

Main pack positive.
Htownblue is offline   Reply With Quote
Unread 04-28-2019, 05:39 PM   #3
Getting Wild
 
bwc_oh33's Avatar
Club Car
 
Join Date: Jun 2018
Posts: 75
Default Alltrax 500 install- 400 amp fuse

Thank you! Now I gotta go get some insulated wrenches because itís spark city trying to get this positive hooked up with the fuse lol


Sent from my iPhone using Tapatalk
bwc_oh33 is offline   Reply With Quote
Unread 04-28-2019, 06:52 PM   #4
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 68,728
Default Re: Alltrax 500 install- 400 amp fuse

Something is wrong

That's not sparking - that's welding
scottyb is offline   Reply With Quote
Unread 04-28-2019, 07:40 PM   #5
Getting Wild
 
bwc_oh33's Avatar
Club Car
 
Join Date: Jun 2018
Posts: 75
Default Alltrax 500 install- 400 amp fuse

Quote:
Originally Posted by scottyb View Post
Something is wrong

That's not sparking - that's welding


Recommendation? Disconnect battery pack completely?

Edit: this was from the main positive with the 400 amp fuse

Sent from my iPhone using Tapatalk
bwc_oh33 is offline   Reply With Quote
Unread 04-28-2019, 09:29 PM   #6
MOD of all BS!
 
NoleFan4Ever's Avatar
Club Car
 
Join Date: Sep 2011
Location: Florida
Posts: 12,220
Default Re: Alltrax 500 install- 400 amp fuse

Disconnect the pack and terminate the Main Pack Negative last. Before you do, get you an incandescent bulb and place it on the post and then place the cable against the thread of the bulb. Wait till the bulb goes dim or out and then quickly attach the cable.

And that is a heavy draw somewhere to pull that kind of current.....
NoleFan4Ever is offline   Reply With Quote
Unread 04-28-2019, 11:10 PM   #7
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 68,728
Default Re: Alltrax 500 install- 400 amp fuse

Quote:
Originally Posted by bwc_oh33 View Post
Recommendation? Disconnect battery pack completely?

Edit: this was from the main positive with the 400 amp fuse

Sent from my iPhone using Tapatalk
Regardless. Something is wrong. There is a dead short there for that kind of metal damage. So go back and check you high amperage cable routes. All 10 or 13 depending upon the system type. Don't make any final connection until you find out why you have such a dead short.
scottyb is offline   Reply With Quote
Unread 04-28-2019, 11:26 PM   #8
Getting Wild
 
bwc_oh33's Avatar
Club Car
 
Join Date: Jun 2018
Posts: 75
Default Re: Alltrax 500 install- 400 amp fuse

Quote:
Originally Posted by scottyb View Post
Regardless. Something is wrong. There is a dead short there for that kind of metal damage. So go back and check you high amperage cable routes. All 10 or 13 depending upon the system type. Don't make any final connection until you find out why you have such a dead short.


Thank you- I will go back and check all cables on controller and solenoid....may have more questions tomorrow. Thanks guys.


Sent from my iPhone using Tapatalk
bwc_oh33 is offline   Reply With Quote
Unread 04-29-2019, 04:23 PM   #9
Getting Wild
 
bwc_oh33's Avatar
Club Car
 
Join Date: Jun 2018
Posts: 75
Default Re: Alltrax 500 install- 400 amp fuse

well Iíve checked all my connection from controller, to motor to solenoid for my high amp cables. Everything appears to be wired to the correct location. I have posted a picture of my solenoid...do I have the washers on wrong? Should it be washer on bottom, terminal connector (red wire from original solenoid positive and diode) then crush washer?


Sent from my iPhone using Tapatalk
bwc_oh33 is offline   Reply With Quote
Unread 04-29-2019, 04:44 PM   #10
Gone Wild
 
Sergio's Avatar
Club Car
 
Join Date: Sep 2012
Location: Charlotte, NC
Posts: 7,528
Default Re: Alltrax 500 install- 400 amp fuse

You should definitely see no light or even feel heat from the light bulb trick above or you have an issue.

I cannot see what is connected to the Solenoid small posts to verify it is wired correctly, is it missing the flyback diode or the connecting wiring themselves?
Sergio is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
12V fuse panel, where to install? Electric Club Car
Fuse for Alltrax Question Electric Club Car
New Alltrax Xct 300 in 08 precedent blowing 15a fuse Electric Club Car
alltrax buss fuse Golf Carts and Parts
fuse block install Electric EZGO


All times are GMT -5. The time now is 08:11 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.