lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-12-2019, 12:57 PM   #1
Not Yet Wild
 
Join Date: Jul 2018
Posts: 13
Default 91 Club Car Bucks when first going

I didnt know exactly how to search for this but when we press the petal from a stop the cart jumps hard and then goes. here are some symptoms i am seeing

1. In forward the cart seems to creep forward on its own, pedal not depressed
2. switching from neutral to forward or reverse the F/R switch sparks
3. the ignition switch doesn't appear to be doing anything (Cart operates whether the key is in the on or off position.

Things I have done
1. went through the wiring diagram and had to move a few wires that werent going to their right places. (the cart ran before but something seemed to be draining the batteries at a furious pace. Cart should be wired according the ther wiring diagram now)
2. New motor
3. New batteries

Parts i will be replacing this weekend
1. forward/reverse switch
2. solenoid

Are there other tings i can check? this is actually my father inlaws cart that i am helping him with.

Thanks in advanced,
Tim
timgroleau is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-12-2019, 04:19 PM   #2
Gone Insane
 
Mooncarter's Avatar
Club Car
 
Join Date: Oct 2016
Location: Richmond, VA
Posts: 7,515
Default Re: 91 Club Car Bucks when first going

I assume this is a resistor cart? Solenoid is stuck.

Replace solenoid first and see what happens.

Unhook battery pack in the meanwhile.
Mooncarter is online now   Reply With Quote
Unread 06-12-2019, 08:35 PM   #3
dliw enoG
 
Fairtax4me's Avatar
Club Car
 
Join Date: Dec 2015
Location: Charlottesburg Va
Posts: 2,167
Default Re: 91 Club Car Bucks when first going

Like MC said, could be a stuck solenoid that's giving power to the motor all the time when in F or R.
Could also have a throttle mechanism adjustment issue.
Fairtax4me is offline   Reply With Quote
Unread 06-13-2019, 07:46 AM   #4
Not Yet Wild
 
Join Date: Jul 2018
Posts: 13
Default Re: 91 Club Car Bucks when first going

Thanks for the reply! I was leaning in that direction. There's still clicking happening when the pedal is pressed but still seemed off the cart was moving regardless of the key position. I'll swap that first this weekend. Thanks for the reply guys!

Quote:
Originally Posted by Mooncarter View Post
I assume this is a resistor cart? Solenoid is stuck.

Replace solenoid first and see what happens.

Unhook battery pack in the meanwhile.
timgroleau is offline   Reply With Quote
Unread 06-13-2019, 08:36 AM   #5
Not Yet Wild
 
Join Date: Jul 2018
Posts: 13
Default Re: 91 Club Car Bucks when first going

Also, yes, it is a resistor cart.

Quote:
Originally Posted by Mooncarter View Post
I assume this is a resistor cart? Solenoid is stuck.

Replace solenoid first and see what happens.

Unhook battery pack in the meanwhile.
timgroleau is offline   Reply With Quote
Unread 06-15-2019, 04:10 AM   #6
Gone Insane
 
Mooncarter's Avatar
Club Car
 
Join Date: Oct 2016
Location: Richmond, VA
Posts: 7,515
Default Re: 91 Club Car Bucks when first going

Any news?
Mooncarter is online now   Reply With Quote
Unread 06-17-2019, 08:34 AM   #7
Not Yet Wild
 
Join Date: Jul 2018
Posts: 13
Default Re: 91 Club Car Bucks when first going

I was able to verify it was indeed the Solenoid. tested the two larger terminals and was getting continuity all the time, even after i removed it from the cart. Replaced the solenoid and the forward and revers switch because we had the part anyways. The cart works like a champ now!!! Doesn't over heat, no sparks, and holding a charge. Thanks everyone for their input here! Huge help!

Quote:
Originally Posted by Mooncarter View Post
Any news?
timgroleau is offline   Reply With Quote
Unread 06-17-2019, 03:12 PM   #8
Gone Insane
 
Mooncarter's Avatar
Club Car
 
Join Date: Oct 2016
Location: Richmond, VA
Posts: 7,515
Default Re: 91 Club Car Bucks when first going

Quote:
Originally Posted by timgroleau View Post
I was able to verify it was indeed the Solenoid. tested the two larger terminals and was getting continuity all the time, even after i removed it from the cart. Replaced the solenoid and the forward and revers switch because we had the part anyways. The cart works like a champ now!!! Doesn't over heat, no sparks, and holding a charge. Thanks everyone for their input here! Huge help!
Mooncarter is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
4 bucks and a six pack aka: 83 Club Car Members Rides
Six Bucks and some Box Wine aka: 97 Club Car Members Rides
Join The 20 Bucks Club ' Announcements
2010 Club Car Precedent Bucks Electric Club Car
2003 Club Car DS Bucks and Surges at First GO Electric Club Car


All times are GMT -5. The time now is 10:30 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.