lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-12-2019, 04:21 PM   #1
Not Yet Wild
 
Join Date: Jun 2019
Posts: 1
Default Not Moving at first time

Hello, I got a Club Car (1996) 48 V. I am noticing the following issue when the car is as rest for various days, I put the key "on", press the pedal and the car does not move. I keep pushing the pedal and suddenly he jumps and moves.

After this, it still works very well all day long.

In addition to this, when it is moving at high speed, suddenly it slows down, as if It is not sending the full voltage to the controller. And so far it starts to run faster.

Any clue? Batteries are new trojans.
Beach306 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-12-2019, 04:30 PM   #2
Gone Insane
 
Mooncarter's Avatar
Club Car
 
Join Date: Oct 2016
Location: Richmond, VA
Posts: 7,045
Default Re: Not Moving at first time

Look underneath. Do you have a box connected to the go pedal toward the DRIVER'S side of the cart?
Mooncarter is online now   Reply With Quote
Unread 06-12-2019, 05:20 PM   #3
MOD of all BS!
 
NoleFan4Ever's Avatar
Club Car
 
Join Date: Sep 2011
Location: Florida
Posts: 10,691
Default Re: Not Moving at first time

MC is right on. You may have the ole potbox and that is the sign of a failing MS and potentiometer.
NoleFan4Ever is online now   Reply With Quote
Unread 06-12-2019, 06:08 PM   #4
Gone Insane
 
Mooncarter's Avatar
Club Car
 
Join Date: Oct 2016
Location: Richmond, VA
Posts: 7,045
Default Re: Not Moving at first time

Quote:
Originally Posted by NoleFan4Ever View Post
MC is right on. You may have the ole potbox and that is the sign of a failing MS and potentiometer.
Mooncarter is online now   Reply With Quote
Unread 06-12-2019, 06:11 PM   #5
Gone Insane
 
Mooncarter's Avatar
Club Car
 
Join Date: Oct 2016
Location: Richmond, VA
Posts: 7,045
Default Re: Not Moving at first time

Beach, click on "Site Sponsors" above. Dave at "REVOLUTION GOLF CARS" is our resident expert on that model. He will be able to confirm or dismiss our diagnosis. He has what you need and the advice to get you running right again.
Mooncarter is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes



All times are GMT -5. The time now is 10:01 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.