lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-19-2019, 12:56 PM   #1
Not Yet Wild
Club Car
 
Join Date: Jul 2019
Location: Charlotte
Posts: 2
Default MCOR4 Testing for 2013 Precedent

Hello and thanks for any and all help. My 2013 CC started surging. I found a post on this forum on how to bench test the MCOR. Checking the 2 wire connection side, continuity was good when micro switch clicked. On the three wire side, I connected multimeter to yellow and white wire MCOR terminals, set mm to 20k. Without turning to activate micro switch ( no throttle simulation) my reading on mm is 4.94. When turned to simulate full throttle mm reading started at 0.15 and slowly went to 0.12. Do these readings indicate a bad MCOR?
wrthomp is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-19-2019, 01:28 PM   #2
Gone Wild
 
Sergio's Avatar
Club Car
 
Join Date: Sep 2012
Location: Charlotte, NC
Posts: 7,538
Default Re: MCOR4 Testing for 2013 Precedent

The 2-pin and the 3-pin are totally isolated and independent.

I assume all wires were disconnected from the 3-pin connector during the resistance test.

The 4.94kΩ with the pedal at rest is good.

Are those last readings (0.15kΩ and 0.12kΩ) the variance in resistance between the Yellow and White wires as you hold the "pedal" all the way down?
Sergio is online now   Reply With Quote
Unread 07-19-2019, 02:02 PM   #3
Not Yet Wild
Club Car
 
Join Date: Jul 2019
Location: Charlotte
Posts: 2
Default Re: MCOR4 Testing for 2013 Precedent

MCOR was without any harness wires attached. To answer your last question, when I simulated full throttle, and when I got it to that point and held it, initial mm reading with probes attached to y and w wires, mm stopped at 0.15 and as I held it open, it dropped to 0.12.

Last edited by wrthomp; 07-19-2019 at 02:46 PM.. Reason: Add clarification
wrthomp is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2013 CC Precedent Build FS Golf Carts and Parts
2013 CC Precedent upgrade gone bad Electric Club Car
2013 Precedent Electric Club Car
2013 club car Precedent vs 2013 EZGO RXV Electric Club Car
2013 Precedent Gas Club Car


All times are GMT -5. The time now is 08:50 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.