lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-19-2009, 07:20 PM   #1
Not Yet Wild
 
Join Date: May 2009
Posts: 4
Default Washed car...Car is dead

Washed car two days ago. Back it out of garage was fie. Washed it. Two days later it still will not move.
Things I have checked:
1) Checked and cleaned all Bat connections.
2) Batt voltage is 50.6.
3) Voltage at selenoid is 50.6 at input ant 49.6 at output in static position.
4) I turn key on, direction lever in foward, push on pedel, I hear selenoid clik, no movement. Put in Reverse, get reverse alarm, still nothing.
Any suggestions.
Granada16 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-19-2009, 08:09 PM   #2
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,060
Default Re: Washed car...Car is dead

Techs will need to know what year and voltage the cart is and what if any modifications it has, Thank you
scottyb is offline   Reply With Quote
Unread 05-19-2009, 08:34 PM   #3
just hangin' around
 
oxfordlawn's Avatar
Club Car
 
Join Date: Jan 2009
Location: Oxford Flo-Rida
Posts: 1,102
Default Re: Washed car...Car is dead

his first post in a different thread suggests he has an 05 Precedent.
oxfordlawn is offline   Reply With Quote
Unread 05-19-2009, 08:46 PM   #4
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,060
Default Re: Washed car...Car is dead

I'm OUT
scottyb is offline   Reply With Quote
Unread 05-19-2009, 09:13 PM   #5
Not Yet Wild
 
Join Date: May 2009
Posts: 4
Default Re: Washed car...Car is dead

Sorry I didn't identify my car. 2005 Precedent Electric. 2007 trojan Batteries. I know this is a common question. I did a search and could not find much on this subject. Maybe wasn't using the right key words.
Granada16 is offline   Reply With Quote
Unread 05-19-2009, 10:04 PM   #6
just hangin' around
 
oxfordlawn's Avatar
Club Car
 
Join Date: Jan 2009
Location: Oxford Flo-Rida
Posts: 1,102
Default Re: Washed car...Car is dead

Quote:
Originally Posted by scottyb View Post
I'm OUT
developing a sore spot for IQ's are ya???
oxfordlawn is offline   Reply With Quote
Unread 05-19-2009, 10:11 PM   #7
Ban Puppy Mills & Stores!
 
scubabud's Avatar
Club Car
 
Join Date: Dec 2008
Location: SE Florida
Posts: 2,945
Default Re: Washed car...Car is dead

Quote:
Originally Posted by Granada16 View Post
Washed car two days ago. Back it out of garage was fie. Washed it. Two days later it still will not move.
Things I have checked:
1) Checked and cleaned all Bat connections.
2) Batt voltage is 50.6.
3) Voltage at selenoid is 50.6 at input ant 49.6 at output in static position.
4) I turn key on, direction lever in foward, push on pedel, I hear selenoid clik, no movement. Put in Reverse, get reverse alarm, still nothing.
Any suggestions.

Sorry, I need to read these things better before I post...

Friend had issues with water getting down his pedal when it rained. You state that you hear a click of the solenoid as well as the reverse buzzer when moving F/R switch. Something got wet so as long as you didn't rinse the bottom undercarriage of your cart getting the motor wet try drying out the pedal and the F/R switch.
scubabud is offline   Reply With Quote
Unread 05-19-2009, 10:33 PM   #8
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Washed car...Car is dead

chances are it just needs to dry out and that may take several days.......have seen a few that took up to 4 days so don,t panic yest.........if the cart does start working again what that tells you is lighten up with the water...................
shadowman is offline   Reply With Quote
Unread 05-20-2009, 09:10 AM   #9
doin it in the desert
 
dock98's Avatar
Yamaha
 
Join Date: Dec 2008
Location: Sonora Desert,Az
Posts: 5,603
Default Re: Washed car...Car is dead

Quote:
Originally Posted by shadowman View Post
chances are it just needs to dry out and that may take several days.......have seen a few that took up to 4 days so don,t panic yest.........if the cart does start working again what that tells you is lighten up with the water...................
i agree
dock98 is offline   Reply With Quote
Unread 05-20-2009, 10:19 AM   #10
Gone Wild
E-Z-GO
 
Join Date: Dec 2008
Location: Liberty Lake, WA
Posts: 476
Default Re: Washed car...Car is dead

I got too much water on everything when cleaning out the battery compartment on my 96. Sneaked the wife's hair dryer and hit the F/R and everything else I could see, took about 20 minutes and she took off. Suggest you use the hairdryer when Mrs. is gone and be sure to wipe it off good before returning it!!
dcannow is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
dead 89 Gas EZGO
dead ez-go Electric EZGO
48v CC dead,everythings dead Electric Club Car
98 TXT Dead Electric EZGO
Dead 2005 EZ-go Electric EZGO


All times are GMT -5. The time now is 12:26 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.