lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-20-2009, 06:28 PM   #1
Not Yet Wild
 
Join Date: Jun 2008
Posts: 17
Default 1990 club car problem

I have a 1990 electric 36 volt v glide with resistor golf cart. here is my new problem. the cart wont go all of a sudden. Has a full charge on display when i move to forward charge light disappears. when i move to reverse buzzer alarms and again displays full charge. still wont move in forward or reverse. V gilde was replaced last year. any help would be appreciated.
ELAZOB is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-20-2009, 07:43 PM   #2
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 1990 club car problem

is your solenoid clicking? 1st start by making sure batteries and cables are all good, clean and tight........once you eliminte that stuff jack the rear of cart up and get a peice of 6 gage cable jump the 2 large post on solenoid than turn key on put in gear and slowly press pedal to floor........if wheels start spinning and things are working than replace solenoid and your done...........good luck and let us know....................................
shadowman is offline   Reply With Quote
Unread 05-20-2009, 07:51 PM   #3
Not Yet Wild
 
Join Date: Jun 2008
Posts: 17
Default Re: 1990 club car problem

ok will try and post back thanks for such a quick response this is the best website you guys always help without selfishness
ELAZOB is offline   Reply With Quote
Unread 05-20-2009, 07:55 PM   #4
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 1990 club car problem

we try otherwise why even come here right.....................its all about trying to help and saving someone a few headaches a a few bucks..............................
shadowman is offline   Reply With Quote
Unread 05-20-2009, 07:58 PM   #5
just hangin' around
 
oxfordlawn's Avatar
Club Car
 
Join Date: Jan 2009
Location: Oxford Flo-Rida
Posts: 1,102
Default Re: 1990 club car problem

Im betting you have a bad connection or corroded cable somewhere. A corroded cable barely making contact will still show full battery charge on a meter, but when you try to use a heavy load it will arc out and lose contact, and moving the f/r switch rewiggles the wires and makes a miniscule connection again. It only takes one good strand of wire in a 6 gauge cable to show 48V on a battery indicator meter, but could never sustain any load.
oxfordlawn is offline   Reply With Quote
Unread 05-23-2009, 04:41 PM   #6
Not Yet Wild
 
Join Date: Jun 2008
Posts: 17
Default Re: 1990 club car problem

tried to jump the solenoid didnt work. also checked all connections the seem tight any chance it could be the forward and reverse switch. when i move the switch to forward or reverse the reverse buzzer sound but the full charge light gets weaker and greater light wise. really stumped the cart was working fine a few days ago.
ELAZOB is offline   Reply With Quote
Unread 05-23-2009, 04:59 PM   #7
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,091
Default Re: 1990 club car problem

What OX said makes sense.... also check for a loose or broken resistor coil...
scottyb is offline   Reply With Quote
Unread 05-23-2009, 08:20 PM   #8
Not Yet Wild
 
Join Date: Jun 2008
Posts: 17
Default Re: 1990 club car problem

i ran my fingers over the restitors nothing seemed cracked i ordered all new wires for the batteries to make sure. will continue to trouble shhot sugestions
ELAZOB is offline   Reply With Quote
Unread 05-30-2009, 09:30 AM   #9
Not Yet Wild
 
Join Date: Jun 2008
Posts: 17
Default Re: 1990 club car problem

replaced all battery wires replaced solenoid and F&R switch still no luck. still wont go any thoughts or ideas before i bring it to a dealer to be fixed?
ELAZOB is offline   Reply With Quote
Unread 05-30-2009, 09:45 AM   #10
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,091
Default Re: 1990 club car problem

There is a no mention so far of the solenoid clicking? Does it click when you press the gas or put it in gear? With the key on? If not check the microswitches at the f&r and 1 in the v-glide?
scottyb is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
1990 Club Car... Electric Club Car
1990 Club Car Speed Controler/V-Glide Problem with Pics Electric Club Car
1990 club car Gas Club Car
1990 Club Car engine?? Gas Club Car
1990 Club Car won't stop! Electric Club Car


All times are GMT -5. The time now is 08:33 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.