lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-29-2009, 09:12 PM   #1
Not Yet Wild
 
Join Date: Mar 2009
Posts: 17
Default 97 DS Club cart goes from slow right to full speed

My 97 DS Club cart goes fine at slow speed but seems to jump right to full speed when I press on the pedal. There is no medium speed , is this the speed controller doing this ? is there a adjustment . This has a wiper speed controller , can this be cleaned maybe a dirty contact. Any help or suggestions would be great. Thank you Ron
clubcar85 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-30-2009, 06:43 AM   #2
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: 97 DS Club cart goes from slow right to full speed

You didnt show voltage of your cart so I must ask for the voltage and then check the following items. Do you have a V glide speed control ( pie shaped unit ) with a resistor set ( large coils ) up or is it a V glide with solid state controller, or a MCOR under passenger floor? In the first 2 cases it could be the V glide or related resistors? If not it could be the MCOR unit and if it is the old unit you will have to purchase the change over kit to update linkage and MCOR.
Please advise with info.
OLD MEC is offline   Reply With Quote
Unread 05-30-2009, 07:15 AM   #3
Not Yet Wild
 
Join Date: Mar 2009
Posts: 17
Default Re: 97 DS Club cart goes from slow right to full speed

Hi this is a v glide with solid state controller. Batteries are brand new trojans T875. There seems to be a dead spot going from slow to fast like there is no medium speed just jumps right to fast. The cart will run great at high or low speed . Can the contacts on the wiper switch be adjusted or cleaned or does this maybe have to do with the controller. Thanks Ron
clubcar85 is offline   Reply With Quote
Unread 05-30-2009, 08:48 AM   #4
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: 97 DS Club cart goes from slow right to full speed

OK you have 8 volt batterys and a V glide so this should be very simple to repair if there has been NO major damage done to V glide unit. There is a cover that clips on toward the drivers side, open it up and look at condition of wiper arm and brush with a mirror and also look at the contacts mounted through outer wall of unit to a series of small resistors on the exterior. I think that this unit only has 4 small guage wires coming out of it? Usually the problem is that the wiper arm brush is worn and or burned to the point of not making good contact through the range of motion. Also check and see if the wiper arm BUSHING is not worn enough to loosen and allow wobble during travel? I think you will find that by replacing the wiper arm brush you should be up and running through full range of speeds? The BRUSH PART NUMBER IS-- 1013860. Also be sure and check the condition of wiper arm SPRING because if its weak the BRUSH will not stay tight to contacts.
If after opening it up you need more parts let me know and I can provide part numbers as needed.
OLD MEC is offline   Reply With Quote
Unread 05-30-2009, 09:27 AM   #5
Gone Wild
E-Z-GO
 
Join Date: Dec 2008
Location: Liberty Lake, WA
Posts: 479
Default Re: 97 DS Club cart goes from slow right to full speed

Old Mec-Just another example of someone taking the time to help with a problem!! What a great explanation you gave to CC85. Even if it doesn't solve his problem your effort proves the value of the Forum. You are one of the many many that makes the project happen. Thanks for the lesson.
dcannow is offline   Reply With Quote
Unread 05-30-2009, 10:34 AM   #6
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: 97 DS Club cart goes from slow right to full speed

Thank you SO MUCH DCANNOW, I for years spent more time on the phone helping people that couldnt afford a mechanics prices and then after retiring for a few years I acted as consultant on commercial HVAC computer controlling and did alot of off site phone work. This is now the next step toward face to face talk ( That I Have on MY COMPUTER ) that will make things even easier to trouble shoot?
Thanks Again DCANNOW.
OLD MEC is offline   Reply With Quote
Unread 05-30-2009, 10:38 AM   #7
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,080
Default Re: 97 DS Club cart goes from slow right to full speed

CHeck the resistors on the back of the v-glide too Somebody could have broken one while putting the new batteries in?
scottyb is online now   Reply With Quote
Unread 05-30-2009, 11:13 AM   #8
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: 97 DS Club cart goes from slow right to full speed

RIGHT ON SCOTTYYB that was my next thing to do after he checks V glide contacts IF THAT DIDNT WORK.
How are you doing CLUBCAR 85, anything to report yet?
OLD MEC is offline   Reply With Quote
Unread 05-31-2009, 05:33 PM   #9
Not Yet Wild
 
Join Date: Mar 2009
Posts: 17
Default Re: 97 DS Club cart goes from slow right to full speed

Hi guy's and thank you so much for all this great advise . My cart is at our campground and I had a graduation party this weekend so never went to try all these great idea's. Will be going there this weekend and will take off the cover of the wiper switch to see what is up. Hoping this will be a easy fix ,will keep you all informed . Thanks again
clubcar85 is offline   Reply With Quote
Unread 06-09-2011, 11:54 PM   #10
Not Yet Wild
 
Join Date: May 2010
Posts: 7
Default Re: 97 DS Club cart goes from slow right to full speed

Too bad we didn't get the follow up solution :(

I have the same problem, somewhat. V-Drive, Controller, 36V-1994 DS club car.
1. Cart only working in FULL speed reverse.
2. Then I jumper the microswitch with the 5 Ohm resistor (White and Black) - Direct to controller....
3. Cart goes only full speed Forward and Reverse.

Ran the cart around the block, and burned up one of the poles on the last battery (black). Maybe because it pulls so much juice at max speed only.

Changed all Microswitches, V-Glide , solenoid, diode and 250 Ohm resistor. I just have to kick myself for buying this cart from a dealer that charged this newbie a little too much for a cart that never have performed...

Any help would be appreciated. Maybe the exact wiring of the V-glide, since I just put on the old resistors

Thanks guys
Ratatass is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
81 Club Car - no slow speed Electric Club Car
Melex 36 Volt Cart only goes at slow speed Melex
marathon in full speed Electric golf carts
81 cc jumps out to full speed Electric Club Car


All times are GMT -5. The time now is 09:06 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.