lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-11-2009, 08:08 AM   #41
Ban Puppy Mills & Stores!
 
scubabud's Avatar
Club Car
 
Join Date: Dec 2008
Location: SE Florida
Posts: 2,945
Default Re: Charger Problem?

Quote:
Originally Posted by blaynef13 View Post
Looks like I am going to have to buy me and OBC. I really appreciate all of y'alls help. I would have never figured this out without you.

BAF
Good luck and please make sure to put your Tow/Run switch in the Tow position and remove both the (-) lead, then the (+) lead before replacing your NEW OBC.
scubabud is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-11-2009, 10:20 AM   #42
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: Charger Problem?

Yeah good luck
and keep us updated on the repair it may help the Next poor addicted soul !
GLEEMO is offline   Reply With Quote
Unread 06-12-2009, 06:47 AM   #43
Gone Wild
 
blaynef13's Avatar
Club Car
 
Join Date: Mar 2009
Location: Big Sandy, TX
Posts: 308
Default Re: Charger Problem?

Will do. Gonna order the OBC today. That having to watch the charger is a pain in the a$$!
blaynef13 is offline   Reply With Quote
Unread 06-18-2009, 07:41 PM   #44
Gone Wild
 
blaynef13's Avatar
Club Car
 
Join Date: Mar 2009
Location: Big Sandy, TX
Posts: 308
Default Re: Charger Problem?

I got the new OBC in and just got through putting it in. It was not NEARLY as bad as I figured it would be. It only took about 45 minutes and 4 beers. It seems to be working. Just checked again and the charger is still going and the needle is going down. The new OBC had a 6ga wire to wire from the battery to the controller with a jumper built in to go from the controller to the accessory mounting terminal(?). I just cut the 6ga and the other wire and wired it directly from the battery to the controller with my existing 3ga cable and wired the other to the accessory terminal. Maybe it worked since it is charging correctly as far as I know.

Thanks for ya'lls help on this.

BAF
blaynef13 is offline   Reply With Quote
Unread 06-18-2009, 08:14 PM   #45
Ban Puppy Mills & Stores!
 
scubabud's Avatar
Club Car
 
Join Date: Dec 2008
Location: SE Florida
Posts: 2,945
Default Re: Charger Problem?

Quote:
Originally Posted by blaynef13 View Post
I got the new OBC in and just got through putting it in. It was not NEARLY as bad as I figured it would be. It only took about 45 minutes and 4 beers. It seems to be working. Just checked again and the charger is still going and the needle is going down. The new OBC had a 6ga wire to wire from the battery to the controller with a jumper built in to go from the controller to the accessory mounting terminal(?). I just cut the 6ga and the other wire and wired it directly from the battery to the controller with my existing 3ga cable and wired the other to the accessory terminal. Maybe it worked since it is charging correctly as far as I know.

Thanks for ya'lls help on this.

BAF
Did you leave a jumper on the receptacle plug or is the charger hot wired?

With the #6 cable removed from the OBC your charger should not turn on.
scubabud is offline   Reply With Quote
Unread 06-18-2009, 08:23 PM   #46
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: Charger Problem?

I think he said he removed the included #6 cable, and replaced where it goes through the OBC with his #3 !

If not through the OBC well hear back :)
GLEEMO is offline   Reply With Quote
Unread 06-18-2009, 08:29 PM   #47
Ban Puppy Mills & Stores!
 
scubabud's Avatar
Club Car
 
Join Date: Dec 2008
Location: SE Florida
Posts: 2,945
Default Re: Charger Problem?

Quote:
Originally Posted by gmorrison View Post
I think he said he removed the included #6 cable, and replaced where it goes through the OBC with his #3 !

If not through the OBC well hear back :)
I hope you're right Garry
scubabud is offline   Reply With Quote
Unread 06-18-2009, 08:42 PM   #48
Gone Wild
 
blaynef13's Avatar
Club Car
 
Join Date: Mar 2009
Location: Big Sandy, TX
Posts: 308
Default Re: Charger Problem?

Yes, it was the included 6ga cable. Just remove the new extras and wired it back in like the old one was.
blaynef13 is offline   Reply With Quote
Unread 06-18-2009, 08:44 PM   #49
Ban Puppy Mills & Stores!
 
scubabud's Avatar
Club Car
 
Join Date: Dec 2008
Location: SE Florida
Posts: 2,945
Default Re: Charger Problem?

Quote:
Originally Posted by blaynef13 View Post
Yes, it was the included 6ga cable. Just remove the new extras and wired it back in like the old one was.
GOOD! Ya had me worried for a bit!
scubabud is offline   Reply With Quote
Unread 06-18-2009, 09:02 PM   #50
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: Charger Problem?

good job !
what had scub worried , was it takes him a six pack to do anything :))
he thought you may have missed a step
GLEEMO is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
EZ Go Charger Problem Electric EZGO
Battery Charger Problem Electric EZGO
Charger problem Electric EZGO
Charger problem Electric Yamaha
Lester charger problem Electric Club Car


All times are GMT -5. The time now is 08:23 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.