lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-15-2009, 07:50 AM   #1
Not Yet Wild
 
Join Date: Jun 2009
Posts: 10
Default 2001 CC help!!

I bought my 01' CC about a year ago and started the rebuild, first i repainted the body with a green bed liner type product then i bought the 6" lift but thats where it stopped for a few months, 6 or 7 to be exact. My problem is this, when i plug in the charger it comes on and runs or charges for about 15 or 20 minutes and the breaker on the charger box kicks!! A friend of mine told me to make sure all of the battery connections were free of corrosion so i spent all day yesterday cleaning and making sure all the connections were tight and clean. Still after all of that, it still kicks the breaker and won't take a full charge. What do i do now?? I'm not real sure how old the batteries are and i haven't took a reading on each battery seperately but the cart will run, just not for very long and going up a steep hill is out of the question!!! After i got my wheels, which is why it sat for the 6 or 7 months, i filled the batteries with distilled water b/c they were low and i didn't think it would even move at all but it did, for about 15 feet, i was stunned!!! There is a light on the dash for i guess voltage and it comes on about every 10 or 15 minutes, it doesn't have a gage, does this have anything to do with my problem??
Also, i'm electricly illiterate so if you can help me you might have to draw me a picture!! LOL!!!

Thanks for any help you can give me.
Bow_hunter40
Bow_hunter40 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-15-2009, 08:03 AM   #2
Ban Puppy Mills & Stores!
 
scubabud's Avatar
Club Car
 
Join Date: Dec 2008
Location: SE Florida
Posts: 2,945
Default Re: 2001 CC help!!

Quote:
Originally Posted by Bow_hunter40 View Post
I bought my 01' CC about a year ago and started the rebuild, first i repainted the body with a green bed liner type product then i bought the 6" lift but thats where it stopped for a few months, 6 or 7 to be exact. My problem is this, when i plug in the charger it comes on and runs or charges for about 15 or 20 minutes and the breaker on the charger box kicks!! A friend of mine told me to make sure all of the battery connections were free of corrosion so i spent all day yesterday cleaning and making sure all the connections were tight and clean. Still after all of that, it still kicks the breaker and won't take a full charge. What do i do now?? I'm not real sure how old the batteries are and i haven't took a reading on each battery seperately but the cart will run, just not for very long and going up a steep hill is out of the question!!! After i got my wheels, which is why it sat for the 6 or 7 months, i filled the batteries with distilled water b/c they were low and i didn't think it would even move at all but it did, for about 15 feet, i was stunned!!! There is a light on the dash for i guess voltage and it comes on about every 10 or 15 minutes, it doesn't have a gage, does this have anything to do with my problem??
Also, i'm electricly illiterate so if you can help me you might have to draw me a picture!! LOL!!!

Thanks for any help you can give me.
Bow_hunter40
Oxfordlawn just replaced his breaker and rectifier and that corrected his problem. Read through the whole thread below:

powerdrive2 charger pops breaker on front
scubabud is offline   Reply With Quote
Unread 06-15-2009, 10:47 AM   #3
Not Yet Wild
 
Join Date: Jun 2009
Posts: 10
Default Re: 2001 CC help!!

Thanks Scuba!!!
I emailed George and he gave me some direction!! Hopefully it's the charger and i can get it fixed quick!!!
thanks again for your help!!!

Bow_hunter40
(Tracy Luckey)
Bow_hunter40 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2001 Cc V-glide Electric Club Car
new to me 2001 cc Electric Club Car
2001 ez go 295 robbin Golf Carts and Parts
2001 EZ-GO Cart will not go! Electric EZGO
2001 EZ G0 TXT Electric EZGO


All times are GMT -5. The time now is 01:06 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.